Can't access site after installation


(Kyle) #1

I installed Discourse per the instructions on github on a box with Ubuntu 15.04. Everything executed successfully however I did not purchase a domain name so I put my IP in the hostname field. Even after getting a success message when running “/.launcher start app” the IP refuses my connection. I’m worndering if it is okay for me to have used my IP as the hostname or if it must be different? I am perfectly happy with navigating to an IP rather than domain name.


(Jay Pfaffman) #2

Did you get this figured out?

If you’re getting a connection refused message then it’s more likely a problem with the port not being accessible from wherever you are.

You could check from a command line with

 telnet ipnumber 80

If it works from the but not elsewhere it’s a problem with port mapping and firewall stuff.


(Kyle) #3

When I run that I get:
root@ITRGAVAPOC011:~# telnet ipnumber 80
telnet: could not resolve ipnumber/80: No address associated with hostname

When bootstrapping/installing via Docker does it not bind to the port
automatically?


#4

It looks like you didn’t replace ipnumber with the actual IP-number of your discourse install. :wink:


(Jay Pfaffman) #5

And if it “works” it’ll look like nothing is happening. You can then type

 get /

And see some stuff that likely looks like gibberish. Then you’ll need to know that control-[ and then q enter will quit telnet. I think that’s it.


(Kyle) #6

So I tried it with the actual IP and no luck, connection refused. Tried looking at IP tables but don’t see any blocking rules. (blocked out my domain). Would I need to create a new rule to allow port 80 specifically?


(Jay Pfaffman) #7

You can try

netstat -atn

To check for open ports.

Maybe you didn’t expose the port in the config file?


(Kyle) #8

Is there a separate config file just for Discourse to set up the ports?


(Jay Pfaffman) #9

Did you follow these instructions?


(Kyle) #10

I did, I’m wondering if it’s because I installed in a corporate lab setting. I did have to add proxies to the app.yml file to be able to reach out to the internet and install. Might be tied to that somehow.


(Kane York) #11

Yep, the proxies are probably what’s going on. The installation is properly listening on 80/443, but the outside world can’t get that far.