Can't add tags to category anymore

I used to be able to be able to add tags to categories here:

but lately, when i try to add e.g. “foo” it tells me “no matches found” but doesn’t allow me to add the tag? am i doing something wrong?

The tag must be existing before you can restrict a tag to be used from a category.

hm… ok. so then how do i create a tag?

Advice to read the tags FAQ.

1 Like

so this tells me “Tags are created upon first usage.” ok, but this leads me into a henn/egg situation: because when i create a tag (while creating a new topic) i get told that this new tag cannot be applied:

which makes sense, because i haven’t allowed this tag for this category (which is what i actually want to do).

it doesn’t feel right that the only way creating a tag would be via “the frontend”. shouldn’t i, as admin, have a chance to create a tag, without actually applying it to a topic already?
(i’m quite positive that this used to be the case in earlier versions)

so you tried to add ‘fixed’ instead of ‘foo’? I thought u wanted to create ‘foo’ and then restrict usage in that same category?

no, i tried to add “foo”. “fixed” already exists.

exactly. thats what i tried in the screenshot i posted above. expecting not a “no matches found” but a “create…” instead.

Create it in a topic that’s in a category without restrictions.

really? that’s the official way to do it?

Well you can not create a tag ‘foo’ in the category where you only allow ‘bar’… it’s conflicting with your own rules.

Create it in another category and then allow it in that category.

Imo creating tags like this is a good way since tags are 99% being created when you actually want to create them for a topic.

On the tags page you can bulk create tags. You need to create a file like the one below and then click the wrench icon > Upload Tags.


The file should be formatted like htis:


You can also format the lines this way to pre-categorize them:


I know this has asked before, but I did not find any real anwer, only type ”it is that way” :wink:

Is there some limitations by code why we don’t have an option to create just one (or several one after one) tag without need to create a file or a dummy post?

You can also create tags from the ‘manage tag groups’ link, though you do have to have/create a tag group first. Not sure if that’s useful to anyone. :slightly_smiling_face:

but being the admin i should be able to just define a tag, before using it.

i see how this can be used as a workaround.

not in my case. i want to, as an admin, prepare a category to be used and pre-define tags for it without actually using them first.

thanks, this is a workaround, but not really a solution.

specifically since this used to be possible in earlier versions and only broke at some point. cannot exactly say when, but could have been around the 2.0 release.

hah, i wasn’t aware of that one. still a workaround, but for my usecase the best one. thanks!

1 Like