Can't authorize/connect with iOS Discourse Hub


(Allan Stromfeldt Christensen) #1

Although I was one of the 1% that had that white screen bug upon Discourse Hub’s initial release, that’s now been fixed – thanks! However, now I have a new problem, that being that I can’t connect to any Discourse instances with the app.

When I first updated to Discourse Hub my connection to Ghost’s forum (automatically) worked perfectly, although the connection to my personal blog’s Discourse forum didn’t work. I realised I needed to update my Discourse instance, and did so. Then arose the problem.

I’ll enter the URL of my Discourse instance (with https://), am sent to the “Authorize application access” page, I log into my account (if I wasn’t already logged in) and tap on Authorize, the blue activity indicator zips across the screen, and that’s it. I tap on Done, which sends me back to the main Discourse Hub screen, and next to my blog’s title is a blue Connect button. I tap on Connect, but that just takes me back to the “Authorize application access” page which does me no good.

I finally got the idea to erase the connection to the Ghost forum, and even the app itself (to see if the problem was just my personal Discourse instance or not), and now I get the same results with not only the Ghost forum but this very Discourse meta forum itself.

If I try and tap on the Connect button I’m just taken back to the “Authorize application access” screen, and tapping on Authorize continues to do nothing, on any instance.

Am I doing something wrong?

In case it’s of any relevance, I’m on an iPhone SE, iOS 10.3.1.

p.s. As you can see in the image I included above, there seems to be an alignment error with the “Discourse Hub” title and the + button – on the iPhone SE form factor at least.


(Stephen) #2

Hey Allan,

I’ve been testing an iPhone 5, which is around the age of the SE without problem, the big difference for me is my iOS version.

Is there something keeping you on 10.3.1? It’s two major releases and almost two years out of date now.


(Allan Stromfeldt Christensen) #3

Haha, I knew somebody would ask that (because it’s totally justified). Yes, I’d totally like to update to iOS 12, but my iPhone is locked to a US carrier, and the only way I was able to get it to work (two years ago) here in Australia was by sticking in this weird R-SIM thing. Meaning, if I update to iOS 12 the R-SIM won’t do its magic anymore and I’ll be locked out of my phone.

Yes, I agree, I need to get a new phone (which with iOS 12 may fix the problem, even though Discourse Hub’s App Store requirement says iOS 9.0?).


(Stephen) #4

Does this help any? Unlock iPhone On iOS 12 / 11.4.1 Using R-SIM And ICCID Changing Trick, Here's How | Redmond Pie


(Allan Stromfeldt Christensen) #5

Weird. Although I can’t authorize/connect to any Discourse instance, I nonetheless received iOS notifications of your messages. So there is some kind of a connection, just not in the fully functional way.

Otherwise, thanks for the R-SIM info. Trying to call that first # didn’t give me any ICCID options, possibly because I need a newer iOS, and/or possibly because I’m on an old R-SIM 11 – the newer R-SIM 12 I purchased a while back didn’t “unlock” my iPhone, maybe because it’s faulty. Nonetheless, with that new information you gave me I may just try purchasing another R-SIM off of a more “reputable” source (rather than eBay) and give this method you linked to me a shot.

Or I may just purchase a new (used) iPhone, which I should probably do if I want to avoid any unwanted and untimely problems.


(Joffrey Jaffeux) #7

Have you tried uninstalling the app and reinstalling it?


(Allan Stromfeldt Christensen) #8

Yup, a couple of times.

It’s due to uninstalling the app that I no longer have the fancy new connection to the Ghost Forum (which I had after the update) and so now also have the blue “Connect” button next to it (as seen in the screen capture up above).


(Joffrey Jaffeux) #9

We will do a new release soon, I’m closing the topic while we wait for this. Reopen if needed.


(Joffrey Jaffeux) #10