Can't clear a grey unread counter on a meta topic due to Whispers


(Michael Downey) #1

Continuing the discussion from Moderate emails which would normally bounce?:

Today I got an unread counter on this 6+ month old topic. Despite reading all the posts, the grey (1) counter won’t clear. Bug?


(cpradio) #2

No, it is Whispers :slight_smile: (really should see what can be done about that, as this comes up regularly)


(Michael Downey) #3

Now I’m feeling suspicious wondering who’s talking behind our backs :wink:

But yeah, it can only lead to confusion…


(Régis Hanol) #4

It was @erlend_sh asking me to clarify some stuff :wink: I guess these questions could have been public.

(I’m starting to dislike whispers due to that specific issue…)


(Michael Downey) #5

As the Apache Software Foundations projects tend to say about their open source work, “if it doesn’t happen [on the list] it doesn’t happen”. :wink:


(cpradio) #6

I’ve been wondering if the simple solution is to mark them as Read if the user is not staff and they visit the topic. But I’m not sure if that won’t have any negative side effects (and the user has read to the end of the topic).


(Robin Ward) #7

I think we should circle back and fix this properly. I discovered the issue far too late into whisper development and we opted to mark the feature as experimental rather than fix.

The problem is the fix isn’t simple, but I think it’s worthwhile to figure it out.


(Régis Hanol) #8

I also agree with @eviltrout. None of the hacks we’ve come up really helps. The only fix is to roll up our sleeves and do the work.


(Jeff Atwood) #9

Whispers work great on email created topics since the people on the other end do not see the topic in the web browser anyway… I think this use case makes a lot more sense anyway.