Can't connect to server

I’m not able to connect to my discourse at all from the web browser. What do I do?

That’s a very open-ended question, with little to go on.

Maybe give us a little information?

  • has it ever worked?
  • how was it installed?
  • where is it installed?
  • what have you tried?

We make best efforts to help here, but you need to give us some real information to work with before that’s possible.

1 Like

Yes, it’s been working fine and suddenly I can’t connect. I’m not sure what to do. It’s installed on a Digital Ocean server.

I can connect to the server fine just when I try to access from a web browser it says it can’t connect.

The domain and everything else is fine.

You’ve verified the DNS is still pointing to the correct IP address of the digital ocean server?

Can you SSH in via terminal to the digital ocean IP address?

Were you using SSL? How was this installed?

Yes the domain works fine. I have a website on there already. My discourse goes to a subdomain. No SSL.

How do I verify that my Discourse is working properly?

Is there anything else I can do? I’ve been using this for years and it suddenly stopped working. Did I get hacked? How do I rebuild?

I tried to rebuild but get this error and the link appears to be broken.

Looks like you have a docker problem. As you still haven’t answered my questions above there isn’t really much to go on here:

  • How was it installed?
  • Where is it installed?
  • How long ago did you install it?

What’s the result of docker info ?

It’s installed on a Digital Ocean Server. I installed it a few years ago. It was installed using the instructions on your website. It worked perfectly fine up until a couple weeks ago.

According to that your Discourse instance is stopped.

See the fifth line: Stopped: 1


cd /var/discourse
./launcher start app

What happens?


I am updating How do I debug docker installation issues which is the topic we pointed you at with debugging steps.


The hello world test doesn’t work so I guess the installation got broken somehow. I might just give up at this point. I’m not very experienced with this and my forums didn’t have a whole lot of activity.

Can I move existing data to a hosted discourse?

If you have a backup, you only need to upload it to your new instance and click the restore button.

Are backups stored on the server? I haven’t done a backup manually.

I don’t understand. Why would my docker stop working? I didn’t do any updates or other changes. It just stopped working.