Can't mute system messages

The Discourse forum I’m using downloads local copies of embedded images, and it sends you a notification every time it does this. This doesn’t affect me and is unimportant and irrelevant to me, so I decided to mute the “system” user:

After doing so though, I still get notifications from system and they create a notification bubble over my avatar:

So I guess this topic is kind of two things in one:

  1. The system account cannot be muted
  2. Downloading local copies of images shouldn’t notify the poster

For this bit, the setting you’re looking for is:

disable edit notifications: Disables edit notifications by the system user when 'download_remote_images_to_local' is active.

It’s in ‘Other’ in admin/site_settings.


You can’t mute system messages, that is by design. You also cannot mute admins, moderators = staff.

1 Like

Alright, thanks Yuun. I’ll ask the site administrators to turn on that setting.

sorry for the necro, but i just discovered (on my site anyways) that the mute setting lets a user enter staff members into the field but the system overrides the notifications. i was able to add both a moderator and myself the admin to my test user account’s mute users field. the ignore field didn’t let me pick staff names, as expected but the mute field did and let me save it (i went back and verified that it saved them). the test account still received notifications and messages as if the staff weren’t muted.