Can't receive emails since I've move the server


(ncl) #1

Hello everyone

Since I’ve moved my server from DigitalOcean to Scaleway, using sparkpostmail
I couldn’t get any email, even admin, so I did

rake admin:create

and upload my backup, when I tried to send a test email,
I got this msg

There was a problem sending the test email. Please double-check your mail settings, verify that your host is not blocking mail connections, and try again.

also my dashboard shows

Some problems have been found with your installation of Discourse:
There are 10 email jobs that failed. Check your app.yml and ensure that the mail server settings are correct. See the failed jobs in Sidekiq. 

the error on the sidekiq

Jobs::HandledExceptionWrapper: Wrapped Net::OpenTimeout: execution expired

I’ve checked my app.yml, nothing changed from my old server

SMTP server address: smtp.sparkpostmail.com
SMTP user name: SMTP_Injection
SMTP port: 587
SMTP password: APIkey

the app.yml setting, does it matter???
DISCOURSE_HOSTNAME: ‘mysite.com

I have no idea what’s going on, my SPF and DKIM are working fine, cuz nothing happened to other sites which are using the same account of Sparkpostmail, plz help, thank you :sob:


(Dean Taylor) #2

Scaleway block outgoing SMTP connections, it’s in their FAQ:
https://www.scaleway.com/faq/server/network/

I cannot send any email.

To avoid spam, remote mail ports (25, 465, 587) cannot be reached from our infrastructure. If you need to open the mail ports to send e-mail, you can go to the advanced options section of your server and change the security group configuration:

  1. On the left panel of the Control Panel, click on “Security”
  2. Select the Security group you want to unblock remote mail ports
  3. Set “Block SMTP” to No.
  4. Reboot your server from the control panel to apply the changes

You could also as an alternative change the SMTP port number to 2525 as SparkPost support this port.


Digital Ocean is blocking outgoing mail!
(ncl) #3

Thank you so much, Dean !!! It works !


(Régis Hanol) #4