Can't run ./launcher rebuild app - Docker storage driver is unsupported

Hi @kraml I made it works in my sandbox server, but when i try the same thing in my production server I have the bootstrap error, and I have my docker working in a partition FSType 1 is mounted fine and I did the steps you mencioned

  • Stop the service
  • Mount the var/lib/docker in the partition
  • restart the daemon
  • start the service (all fine)
  • go to /var/discourse
  • launch the bootstrap and have the same error

    Any advice?

The log you copied in screenshot don’t help in diagnose the problem, you need to provide the full rebuild log.

It is high probable that one of your plugin caused the rebuild problem, if you are sure you have done the right steps regarding filesystem.

1 Like

The final step was rename folder /var/discourse, and make a new install, good luck i have a backup and now my site is up and with all the data.


thanks! I can confirm that this works great on a Linode running Ubuntu 14.04. Note that I was not able to actually stop the app because of the launcher storage driver error message.


This seems to be the only thing that worked on my Ubuntu 16.04, thanks! :slight_smile:


In a similar situation (Debian 8 Jessie)

“Your Docker installation is not using a supported storage driver”

Docker info
Storage Driver: devicemapper

# cat /etc/debian_version

# dpkg --get-selections | grep linux-image
linux-image-3.16.0-4-amd64          install
linux-image-amd64                   install

# dpkg -L linux-image-3.16.0-4-amd64 | grep aufs

Solution was to create new file: /etc/docker/daemon.json

  "storage-driver": "aufs"
service docker restart

This basically saved my life. Worked like a charm in my EC2 Linux instance and relived it.


According with:

For Ubuntu 14.04 version, you must install linux-image-extra-* package before install docker.
So if you already installed docker, you should uninstall it first before start to install linux-image-extra-* package.
sudo apt-get purge docker-ce
sudo rm -rf /var/lib/docker
sudo rm /etc/systemd/system/docker.service

Then install linux-image-extra-*

sudo apt-get update

sudo apt-get install \
    linux-image-extra-$(uname -r) \

and finally reinstall docker from git

wget -qO- | sh

regards :ok_hand:

1 Like

i fount a fix for this if it still dosnet work do: cp /etc/systemd/system/docker.service /lib/systemd/system/docker.service that fixed my issue


tried @mpalmer solution but can’t rebuild.

With docker info | grep Storage I get

WARNING: No swap limit support
WARNING: the aufs storage-driver is deprecated, and will be removed in a future release.

Anyway when I try to rebuild it shows:

Your Docker installation is not using a supported storage driver. If we were to proceed you may have a broken install.
aufs is the recommended storage driver, although zfs/btrfs/overlay and overlay2 may work as well.
Other storage drivers are known to be problematic.
You can tell what filesystem you are using by running “docker info” and looking at the ‘Storage Driver’ line.

> ps ax |grep dockerd

864 ? Ssl 0:00 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock -s aufs
1664 pts/0 S+ 0:00 grep --color=auto dockerd

> cat /etc/lsb-release


What am I missing?

Please update the launcher:

cd /var/discourse
git pull

after that you will be able to rebuild.


Thanks @Falco. It works now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.