"Your Docker installation is not using a supported storage driver."

Hi, first-time Discourse user with not much tech knowledge.

I have installed Discourse on Lightsail Ubuntu 18.04.2 using the official instructions. Forum up and running no problem.

Now tried to install a plugin: Install Plugins in Discourse

./launcher rebuild app gives this error

“Your Docker installation is not using a supported storage driver. If we were to proceed you may have a broken install. aufs is the recommended storage driver, although zfs/btrfs/overlay and overlay2 may work as well. Other storage drivers are known to be problematic. You can tell what filesystem you are using by running “docker info” and looking at the ‘Storage Driver’ line. If you wish to continue anyway using your existing unsupported storage driver, read the source code of launcher and figure out how to bypass this check.”

Have searched for the same message in this forum and I am not clear exactly what to do from the replies.

Docker info on my set-up gives overlay2.

Not sure how Discourse can install ok, then the plugin install/rebuild not work.

Between installation and the plugin install/rebuild attempt, I have only updated Discourse and docker manager as per a notification, and performed apt-get update and apt-get upgrade.

Can someone clarify whether overlay2 can work? Or whether aufs is needed? What exactly are the instructions I need to follow to get the plugin install working?

Many thanks
Maynard

1 Like

Can you please run docker info and paste the output here?

4 Likes

Many thanks for the quick reply. Here is the output from docker info:

Client:
 Debug Mode: false

Server:
 Containers: 1
Running: 1
Paused: 0
Stopped: 0
 Images: 2
 Server Version: 19.03.1
 Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 894b81a4b802e4eb2a91d1ce216b8817763c29fb
 runc version: 425e105d5a03fabd737a126ad93d62a9eeede87f
 init version: fec3683
 Security Options:
apparmor
seccomp
Profile: default
 Kernel Version: 4.15.0-1044-aws
 Operating System: Ubuntu 18.04.2 LTS
 OSType: linux
 Architecture: x86_64
 CPUs: 1
 Total Memory: 1.945GiB
 Name: ip-172-26-45-250
 ID: X2FT:FW3R:QQM2:BNNU:4L3L:QYEV:WMI4:IC2T:LHJV:UNSG:RYHH:OWJ7
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
127.0.0.0/8
 Live Restore Enabled: false

WARNING: No swap limit support
3 Likes

Oh I think I know what is happening.

Try:

cd /var/discourse
git pull
./launcher rebuild app
6 Likes

Many thanks again for the quick reply.

Adding the git pull worked and the data explorer plugin is now working.

2 Likes

Strange. What was it?

2 Likes

Well, long story.

Docker 19.x changed the whole structure of the docker info output.

We fixed that when 19.x was still on the beta branch more than a month ago at FIX: Make storage detection compatible with docker 19.x · discourse/discourse_docker@98c5fec · GitHub. The fact that our launcher script auto-updates makes this a non-issue for most people.

However, our launcher script checks for the storage compatibility before auto-updating. So people who have an old launcher and update docker before updating launcher can get into that state.

6 Likes

It’s not the first time we’ve run into this, could launcher not update first and then ask the user to re-run?

2 Likes

Yeah it should, would you like to give that change a shot?

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.