Can't send email with Namecheap


(Samuli Natri) #1
  1. I can login to Namecheap webmail using MYMAIL & MYPASS

  2. Redmine can send emails with Namecheap using this configuration:

     enable_starttls_auto: false
     address: mail.privateemail.com
     port: 25
     authentication: :login
     user_name: MYEMAIL
     password: "MYPASS"
    
  3. Emails work with gmail using this configuration:

    DISCOURSE_SMTP_ADDRESS: smtp.gmail.com # (mandatory)
    DISCOURSE_SMTP_USER_NAME: MYMAIL # (optional)
    DISCOURSE_SMTP_PORT: 587 # (optional)
    DISCOURSE_SMTP_PASSWORD: MY_APP_PASS # (optional, WARNING the char ‘#’ in pw can cause problems!)
    #DISCOURSE_SMTP_ENABLE_START_TLS: false

  4. This setup says “sent” when sending test mail, but it doesn’t deliver the mails.

    DISCOURSE_SMTP_ADDRESS: mail.privateemail.com # (mandatory)
    DISCOURSE_SMTP_USER_NAME: MYMAIL # (optional)
    DISCOURSE_SMTP_PORT: 25 # (optional)
    DISCOURSE_SMTP_PASSWORD: MYPASS # (optional, WARNING the char ‘#’ in pw can cause problems!)
    #DISCOURSE_SMTP_ENABLE_START_TLS: false # (optional, default true)

  5. I also tried ports 465, 587 and 25 with both TLS on and off (rebuilt it with every test)

  6. This is installed by the one-click installer in digitalocean. Should I install this manually?


(omfg) #2

Don’t try miscellaneous settings. Use the correct settings required by your email service provider.
https://www.namecheap.com/support/knowledgebase/article.aspx/1179/2175/general-configuration-for-mail-clients-and-mobile-devices


(Alex) #3

An alternative can be to offload the sending of e-mails to a 3rd party provider, I’ve used SendGrid for this in the past. If you send less than 12,000 emails per month, their free plan will suit you just fine. In addition, you get some nice features such as analytics.


(Samuli Natri) #4

Thanks a lot, this worked!


(Samuli Natri) #5

Yes I tried the settings on that page. Any of these settings worked:

Outgoing server (SMTP): 465 port for SSL, 25 or 26 for TLS/STARTTLS
Outgoing server authentication should be switched on, SPA (secure
password authentication) must be disabled.