Can't send mail - 554 Blacklisted

Hi,

I try to instal Discourse on my server as Docker container. Everything is fine until sending email on the first run.
I didn’t receive mail.

I run discourse-doctor and this is the result (I’ve changed domain to MY_DOMAIN):

DISCOURSE DOCTOR Thu Mar 28 20:21:39 CET 2019
OS: Linux MY_DOMAIN 4.9.0-7-amd64 #1 SMP Debian 4.9.110-3+deb9u2 (2018-08-13) x86_64 GNU/Linux


Found containers/app.yml

==================== YML SETTINGS ====================
DISCOURSE_HOSTNAME=forum.MY_DOMAIN
SMTP_ADDRESS=mail.MY_DOMAIN
DEVELOPER_EMAILS=REDACTED 
SMTP_PASSWORD=REDACTED 
SMTP_PORT=587
SMTP_USER_NAME=admin@MY_DOMAIN
LETSENCRYPT_ACCOUNT_EMAIL=REDACTED 

==================== DOCKER INFO ====================
DOCKER VERSION: Docker version 18.06.1-ce, build e68fc7a

DOCKER PROCESSES (docker ps -a)

CONTAINER ID        IMAGE                                    COMMAND                  CREATED             STATUS              PORTS                                                                                                                                                                                    NAMES
1f8189961b0b        local_discourse/app                      "/sbin/boot"             13 minutes ago      Up 13 minutes       80/tcp, 443/tcp                                                                                                                                                                          app
1a6cfa219f03        jrcs/letsencrypt-nginx-proxy-companion   "/bin/bash /app/entr…"   4 hours ago         Up 4 hours                                                                                                                                                                                                   nginx-proxy-le
0aa8ab53cbd0        jwilder/docker-gen                       "/usr/local/bin/dock…"   4 hours ago         Up 4 hours                                                                                                                                                                                                   nginx-proxy-gen
466653c3d497        nginx                                    "nginx -g 'daemon of…"   5 months ago        Up 5 hours          0.0.0.0:80->80/tcp,     0.0.0.0:443->443/tcp                                                                                                                                                 nginx-proxy
cbd9c3a891a4        analogic/poste.io                        "/init"                  5 months ago        Up 5 hours          0.0.0.0:25->25/tcp, 0.0.0.0:110->110/tcp, 80/    tcp, 443/tcp, 0.0.0.0:143->143/tcp, 0.0.0.0:587->587/tcp, 0.0.0.0:993->993/tcp, 0.0.0.0:995->995/tcp, 0.0.0.0:4190->4190/tcp, 465/tcp   poste-io


Discourse container app is running


==================== PLUGINS ====================
          - git clone https://github.com/discourse/docker_manager.git

No non-official plugins detected.

See https://github.com/discourse/discourse/blob/master/lib/plugin/metadata.rb for the official list.

========================================
Discourse version at forum.MY_DOMAIN: Discourse 2.3.0.beta6 
Discourse version at localhost: NOT FOUND
==================== DNS PROBLEM ====================
This server reports NOT FOUND, but forum.MY_DOMAIN reports Discourse 2.3.0.beta6 .
This suggests that you have a DNS problem or that an intermediate proxy is to blame.
If you are using Cloudflare, or a CDN, it may be improperly configured.


==================== MEMORY INFORMATION ====================
OS: Linux
RAM (MB): 3084

              total        used        free      shared  buff/cache   available
Mem:           3012        1729         257          84        1025        1010
Swap:          1020          19        1001

==================== DISK SPACE CHECK ====================
---------- OS Disk Space ----------
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        97G  6.4G   86G   7% /

==================== DISK INFORMATION ====================
Disk /dev/sda: 100 GiB, 107374182400 bytes, 209715200 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xe0740020

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1  *         2048 207620095 207618048   99G 83 Linux
/dev/sda2       207622142 209713151   2091010 1021M  5 Extended
/dev/sda5       207622144 209713151   2091008 1021M 82 Linux swap / Solaris

==================== END DISK INFORMATION ====================

==================== MAIL TEST ====================
For a robust test, get an address from http://www.mail-tester.com/
Sending mail to REDACTED  . . 
Testing sending to admin@MY_DOMAIN using admin@MY_DOMAIN:PASSWORD@mail.MY_DOMAIN:587.
======================================== ERROR ========================================
                                    UNEXPECTED ERROR

554 Blacklisted; please try again later or contact administrator


====================================== SOLUTION =======================================
This is not a common error. No recommended solution exists!

Please report the exact error message above to https://meta.discourse.org/
(And a solution, if you find one!)
=======================================================================================

==================== DONE! ====================

I’ve tested manually by mail-tester.com . mail-tester.com result is: 8.9/10
I have small issue with

SpamAssassin: -1.1

Anyway I can send and receive mail on this address.
How can I resolve this problem? :frowning:

That message is coming from the SMTP server. It is not accepting mail from your Discourse server.

Whoever is in charge of mail.MY_DOMAIN is who you need to talk to. If it’s you, then you need to check your logs and google “554 blacklisted your-mail-server-software”

4 Likes

I use server mail as poste.io . It’s dockerized mail server and I host on the same server.

I’ve checked another server (also dockerized by poste.io ) and I’ve got 500 Unrecognized command .
Maybe someone configured Discourse with poste. io ?

Is there a reason you’re not using one on the recommended free providers?

2 Likes

Maybe so. You should ask people who know about poste. io and see what they have to say.

2 Likes

I checked elasticmail. But still doesn’t work. I used settings from @Stephen post and set admin account as one on my gmail account.
All settings are ok, becuse when I run discource-doctor I’ve got SMTP server connection successful and Mail accepted by SMTP server.
I’ve checked inbox, spam folder - no mail.

Elasticmail says Today email sent: 0 .

Discource base is in 2.0.20190321-0122 version .

It’s hard to explain how discourse-doctor would report that the mail sent successfully and that Elasticmail would not have the message in the logs. The only explanation I can imagine is that the ElasticMail credentials that you used are not for the same account that you’re checking the logs of. That seems wildly improbable.

I’ve checked twice. Everything is ok. It is very weird :pensive:
I’ve tried different mail as administrator - still doesn’t work.