Can't update since Git Pull "Already up to date"

Priority/Severity: Normal

Platform: Digital Ocean / Own / 2.9.0.beta5

Description: I’m on 2.9.0.beta5 want to update to 2.9.0.beta10, but when I wrote in Terminal "git pull’ it says “Already up to date”. Also, rebuild is not working.

Reproducible steps: Typing git pull in terminal says “Already up to date”. Typing ./launcher rebuild app.

What do you get from docker ps ?

1 Like

Should I type docker ps into console? Sorry for dumb questions, but I’m literally guide-follow person, not a programmer. Hope you’ll understand :pray:

I’m also must to say that it allow me upgrade using Discourse upgrade, not via Terminal. First of all it allow me upgrade only Docker. After that it will allow me upgrade all another. But I’ve tried to open that page after docker update and this page told me to do:

cd /var/discourse
./launcher rebuild app

these steps. Which bring us to a question: how to upgrade if rebuild app is not working for me for some reason.

Only doing git pull sometimes does not give you the latest commits. You can use git pull origin main if you are using Github for version control. For other version control platforms, it is usually git pull origin master.

A pull is a fetch and a merge: git pull = git fetch + git merge

git pull origin main fetches commits from the main branch of the origin remote (into the local origin/main branch), and then it merges origin/main into the branch you currently have checked out. ().

After a fresh clone doing git clone you will have a local branch “main”, a remote “origin” and your main branch has “origin/main” as upstream.

git pull only works if the branch you have checked out is tracking an upstream branch. For example, if the branch you have checked out tracks origin/master, git pull is equivalent to git pull origin main

You can see your state of repository and staging area with the git status command.
For example, here below is the result of git status on my repository:

On branch main
Your branch is up to date with 'origin/main'.

nothing to commit, working tree clean

Other useful links
For a more in-depth explanation of the differences between the different git pull commands, you can see the following pages:

I never use git when upgrading Discourse. I just use the two lines above. I think for years the rebuild script has included the necessary git command. I hope that is correct.

That’s correct, there’s no need to specify the branch of discourse-docker and any pull of the discourse repo is handled by launcher.


Yea, but nothing is happening when I trying to

./launcher rebuild app

It just do nothing, but it started recently. On previous versions everything worked great. How can I handle this issue?

As you can see launcher did not work at all.

No response to “stop” or to “start”.

How was this instance installed?

Digital Ocean provides droplet with pre-installed Discourse. So I’ve used it.

If you mean the one-click install we don’t support that here, so I’ve tagged this unsupported-install. The free support here focuses on the standard install.

Have you considered raising a ticket with DigitalOcean?

1 Like

That’s very strange. What does

     docker ps


1 Like
1 Like

This thing:

Okay, I found a solution:

Just do in a order:

wget -qO- | sh
service docker start
git pull
git stash
git stash drop
git pull
./launcher rebuild app

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.