Can't upload backup - run out of disk space


(Dave Higgins) #1

I’ve followed the instructions (this and this) to get a local developer Discourse running. It seems to have worked, and I am browsing at http://localhost:4000/ as admin. I would now like to upload the backup of my working cloud Discourse (a new install on DigitalOcean, the backup file is only about 4MB). The plan is to hack away on the local version.

My backup upload fails with

“There has been an error while uploading ‘my-discourse-2016-04-04-131830.tar.gz’: There is not enough space on disk to upload this backup.”

Back to the local developer Discourse, here is an image of the output from the ssh to the VirtualBox VM when I try to upload the backup (I am not sure if it will help):

I am not sure how to proceed - any ideas?


(Dave Higgins) #2

This issue remains not solved, but here’s my workaround for getting the Discourse backup into the VM.

  1. [Get your VM up: Start Github, open Git shell, vagrant up, vagrant ssh]
  2. Start Filezilla on your host.
  3. Connect to 127.0.0.1:2222 via SFTP with username: vagrant and password: vagrant
  4. Copy the Discourse backup to /vagrant/public/backups/default
  5. Back in the Git shell, start the rails instance bundle exec rails s -b 0.0.0.0
  6. In browser http://localhost:4000/admin/backups see your backup listed.
  7. Click restore (assuming in Discourse Settings, “allow restore” is checked)

After successfully uploading and restoring my backup, here’s a df -Pk


(Angel Raul Molina Muñoz) #3

Works for me, in my case installing Discourse on my OS X so /public/backups/default :thumbsup: