Category Banners component not compatible with 3.2.0.beta2

I updated the category-banners component yesterday on a site running 3.2.0.beta2 and the banners no longer appear. I think it is because of this change:

In particular, I think this change causes the component to require API version 1.15.0, whereas the latest beta is only at 1.14.0.

From a quick look, I can see that the component requires 1.13.0 for renderInOutlet, but I don’t think it should require 1.14.0 or 1.15.0, should it?

Have you done a rebuild lately? I suspect that you need a new base image.


Thank you very much for the reply. I’m sure you are correct that the component works on the latest tests-passed version, but I prefer to stick to the beta releases when possible. My post was partly meant to be a warning to anyone else who sticks to the betas like me, and partly a hint to the team that perhaps the API version requirement for this component is more strict than it needs to be.

I think it’s a bug because the .discourse-compatibility file specifically lists revision 1398eeeff550c1da186a47b6d3878d3230f62340 as working with 3.2.0.beta2, and I don’t think there’s any way it can.

1 Like

Are you running a particular version of a beta tag? If so, can you let me know which beta tag you are on so that I can have a look?

In the compatibility file we have < 3.2.0.beta2: 1398eeeff550c1da186a47b6d3878d3230f62340 which states the any Discourse version smaller than 3.2.0.beta2 will pin the theme to the 1398eeeff550c1da186a47b6d3878d3230f62340 commit hash.

Hi @tgxworld, thank you for the reply.

Yes, I’m running the v3.2.0.beta2 tag (be04154838):

The plugin API version supported by this release is 1.14.0:

Revision 1398eeeff550c1da186a47b6d3878d3230f62340 of discourse-category-banners requires API version 1.15.0, which is not available in v3.2.0.beta2

API version 1.15.0 was added in this commit:

…which has not been released as a beta yet.

To resolve this, I think that the theme component could just require API version 1.13.0 instead (the one that introduced api.renderInOutlet), which is part of v3.2.0.beta2.


@simonk Thank you for doing the digging. This is a bug on our end and I have fixed this in


@tgxworld thank you! I can confirm that the component is working again on my site running v3.2.0.beta2 :+1:

I wonder if you should edit the .discourse-compatibility file though. At the moment, anyone running versions between 3.1.999 and 3.2.0.beta2 will be given a version that depends on plugin API version 1.15.0. They should probably be pinned to 65a2cfc43fb5f6ffd2f8db3888552594ed21c501 instead (the commit before the refactor).

This topic was automatically closed after 20 hours. New replies are no longer allowed.