Category search function not working

Hi. My category search function isn’t working.

Screen Shot 2020-05-18 at 18.57.15

The screenshot is from ‘new topic’, but it’s the same when editing a category, or moving posts between categories.
(I’m not referring to newly created categories that might require a refresh, but to all of them.)

It’s working in yours, I checked before posting, so any suggestions would be appreciated.

Thanks!

1 Like

Is there something unusual about your categories? If we can’t repro it here or on try.discourse.org that indicates it is possibly a local config problem.

Hi Jeff,

I’ve tested on my phone, a different browser, a guest account, and they none of them have a working search function.

If there is anything unusual about my categories, it’s unintentional.
Where can I check / reset things?

Thanks!

1 Like

You can try looking at your site in safe mode - if that works, then you know it’s a most likely a theme component or third party plugin.

https://SITEURL/safe-mode
4 Likes

Hi Tobias, thanks for your suggestion.

I went into safe mode and tried, but still nada:
Screen Shot 2020-05-19 at 15.04.56

It’s as if they don’t load. The “No match” reply occurs instantly, from the moment I start typing the first letter…

2 Likes

Sorry to hear you continue to have trouble with this… it must be frustrating!

You’ve probably checked all this but… do you have unusual category security settings limiting access? Does the user account have access to post to any category?

1 Like

Hi Tobias, thanks for thinking along!

My admin account has access to everything.
But I had left one thing untested: an incognito window.
And lo and behold: it works there, both for my test account and for admin.

So then I thought some setting in my regular browsers must be interfering, like maybe my AdBlocker ‘preventing pop-ups’, but I’m using my regular browser with AdBlocker for this Discourse instance as well, and ‘search’ works here on Meta - but not on mine.

So that would imply a setting in my Discourse instance - one that also affects performance in safe mode.

Hang on… that wouldn’t explain it working in incognito… dang…

Does anything come to mind for you?

Edit: The adblocker does interfere.
For a moment there i thought that resolved everything, but unfortunately not…

3 Likes

Interesting, great catch – I guess one of the categories must have the words “ads” in it? :thinking:

3 Likes

Actually, I was wrong, :frowning: or at least partially:
It now works on some searches, like when you’re in a category and you want to find a specific sub-category. But it still doesn’t work in others.

Will dive back in in a few days. I really need to spruce up some categories, but seeing how the search function works incognito, I’ll do it there.
Meanwhile I’ll just let it stew for a bit, see if I (or you, :smiley: ) have any other epiphanies…

Meanwhile thanks for your help!

3 Likes

The next time it happens, try to check if there’s any errors in your browser console. It’s usually a pretty good indicator.

2 Likes

You’re not going to believe this… :rofl:

spot the difference:
Screen Shot 2020-05-20 at 18.12.48 Screen Shot 2020-05-20 at 17.51.50

Being unable to interpret the details of Joe’s suggestion (but still: thanks!) I asked someone else to dig into that for me.
Him: “But it works…”
Turns out my search function doesn’t like capital letters…

This doesn’t apply to other browsers: my incognito takes capitals just fine!
Your Meta Discourse -for me- also doesn’t accept capitals. the first time I checked, a few days ago, I didn’t use capitals because you don’t use them in your category title.

4 Likes

Huh. I have repro here on meta. Type in “s” and matching categories show up. Type in “S” and no matching categories. That’s interesting!

In safari and chrome on my mac, and chrome on my iphone.

3 Likes

I went back to check I was right about my guest browser (cos yes/no using capitals isn’t something I paid any attention to in all the testing).
Turns out that in the category listings search works with capital, but not when you’re in a topic and want to move that topic to another category.

2 Likes

I thought we dealt with this @techapj? I hate case sensitivity…

3 Likes

This will be fixed by:

Thanks for report :+1:

6 Likes

Hi Joffrey, thanks, I see this works on this site.
But… Installing/executing the above is way outside my competence, so: will the next update fix this for me?

thanks!

1 Like

Yes it will be in next update for sure.

4 Likes