Changes to copy/paste? Pasting formatted text inserts markdown


(Arnold Schrijver) #1

Was there a recent change to the Copy/Paste feature within the message dialog?

I am noticing that formatted text now automatically leads to text with markdown commands in it, after I paste. This is for me not an ideal situation. I type markdown myself, but now when I copy a link in my markdown, it is broken, because the paste already is a complete link. Also when creating a bulleted list from headers I copy from an article, every entry has ### asterisks in front of them, that I have to manually remove.

Tried pasting to my own Gitea, and this does not have this, so seems not to be a FF browser feature (I use FF 61.0.1 on Ubuntu 16.04).

If this is a new feature, can I turn it off?

Note: this concerns community.humanetech.com


(Jeff Atwood) #2

Use the CTRL+SHIFT+V support built into your browser. If you wish to disable the default turn off enable rich text paste in your site settings.

This was requested functionality, see HTML/RTF pasting


(Arnold Schrijver) #3

Thank you for your help, @codinghorror !

Ah, missed that page when searching (searched for ‘markdown’ + ‘paste’). I have disabled the site setting.


(system) #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.