Changing Discobot Responses in Tutorial

Hey I realizing changing the responses in the Discobot tutorial may not necessary change the accepted answers or is not working. The two times I tried to edit the links to copy and paste they went missing.

I’m not sure if this caused the problem or if theres another place where the answers would be held. But it wasn’t accepting the links.

I had saved specific links for example:
https://rapyd.net or https://docs.rapyd.net but then when I went back it showed the following:

I had to revert back to the original where these remained.

How can I change the links where it doesn’t go blank and it works?

1 Like

Hey!

Just checking in, I have the same issue, it seems to be related to the < >

Image from Gyazo

Image from Gyazo

As you can see the wikipedia links have the < >, quite strange.


Just letting you know, removing the < > does not resolve the issue.
2 Likes

I think this may be a #bug

2 Likes

I’m looking at some Discobot stuff later, and I shall add this to the task. :+1:

2 Likes

Thanks! @JammyDodger and @jimmynewtron!

Any updates @JammyDodger. We do have a lot of people joining our community and would love to set this up!

I can confirm that adding a custom link does clear all of the links in discourse_narrative_bot.new_user_narrative.onebox.instructions. The surrounding < > are not shouldn’t be the issue as they are simply to ensure the link is displayed ‘as is’ and not oneboxed.

I’m afraid I do not know whether this is expected or not as yet. But in the meantime I suggest resetting the field and using the existing ones. :+1:


@Kyle_Pollock

Okay, scrap that answer. I think I know what’s happening. :slight_smile: The < > that ensure the links stay as text and aren’t oneboxed are making the sanitizer think they’re some HTML code that’s not allowed to be in there and is cleaning them up on save.

But if you hyperlink the address in markdown instead then this seems to work as you want it to. eg

[https://meta.discourse.org](https://meta.discourse.org)

Update: Using a regular <a href="https://meta.discourse.org">https://[test.site](http://meta.discourse.org)</a> style link also seems to work :+1:

Could you give that a try while we look into it further?

1 Like

Hey @JammyDodger, I’ve gone ahead and tried that out, however I seem to encounter the issue of Sorry, I could not find that link. Any ideas?

I tried using the following [https://meta.discourse.org](https://meta.discourse.org) however I found no success, thanks for taking a deep look into it though.

2 Likes

Hmmm. :thinking: It worked for me. You may be hitting the problem in the other recent Discobot-related topic - Discobot didn't recognize link in tutorial Could you give that a look over and see if it sounds familiar?

Looking at your screenshot it doesn’t look like your link oneboxed up, so it could be that.

Thanks I’m in the same situation. Link sticks but doesn’t get recognized in the tutorial. I’ll move over to the other thread to reply.

I’m in the same situation

Thanks, @JammyDodger happy new year. Just following up on this issue. Would love to know if these changes can be made as a Discourse admin or you need to go into the source code to change?

Thanks,

1 Like