Cloudflare Tunnel Pi Help

So I had the Discourse software up and running fine yesterday, and I woke up today ready to handle the task of setting up my tunnel with Cloudflare. I’m pretty sure I followed all the steps correctly etc.
However I must be mistaken since I can no longer access the site. I tried running it both as a service and just as itself with no luck.

The error I’m getting from the Service is this:

Failed to serve quic connection error="Unauthorized: Failed to get tunnel" connIndex=0
Register tunnel error from server side error="Unauthorized: Failed to get tunnel" connIndex=0

From that I can tell something is off with my authorization, however I’m not entirely sure what since I’ve put the .perm file into the /home/dev/.cloudflared/ directory with no luck. I’m at a lost here and I will probably need more help after getting this to work too. :slight_smile:

Sorry for the hinderance, but thanks in advance for the support this community gives. <3


You haven’t set up the cloudflare daemon cloudflared correctly. It seems like you haven’t set up the tunnel properly.

refer to this guide for more info.


I followed that guide thoroughly, however I did mess up on my first installation so I’ve wiped the drive for now and will try again since I installed Discourse before I installed Cloudflared onto the device and hopefully will have a better time with it this instance.

It shouldn’t matter what is installed first. You just have to authenticate and configure the tunnel for correct port and it should work.

Weird, I’m pretty sure I had it setup correctly, like a good 90% sure that I did everything right since it was running the tunnel, or at least it was when using the cloudflared tunnel run command.
However trying to run it as the service it wasn’t having any luck and I wasn’t able to get into Discourse even when it was the command above so I’m not 100% sure since I made sure to follow the steps one by one. Though I’m obviously wrong since it wasn’t working. :’)

I’ll have to set it up again now though with the knowledge I know now it should be quicker.


Re-installing it after actually messing around with it seemed to be the thing I needed. Just installing Discourse now and then that should be that, however I do have another Pi I’m trying to run websites from. However I can’t seem to connect to them, I haven’t really messed with this stuff before so I’m a little confused since the way I see it is that shouldn’t the tunnel allow me to both run Discourse on one Pi and then Nginx or Apache on another?

Thanks again,

Okay so I installed cloudflared properly this time, it started without an issue and was fine. however the issue I am now facing is that I cannot connect to my other Pi which has my website on it and I haven’t changed anything with the ports for that site since I am assuming the tunnel is supposed to help with that no?

I’m using Nginx for those sites, however I also have the problem of not being able to access my Discourse site, it’s saying clearing my cookies as it’s giving too many redirects. I have tried making the CNAME rule be DNS only since I’ve seen it has fixed this issue before, but this is with no luck.

Is it because I have another machine opened with the same ports? I’m assuming so, then how would I work around this? Would I need to make my websites open on different ports compared to the Discourse one, also to why I can’t connect to the Discourse setup is beyond me I’m confused to why I’ve got that error.

I actually have this error when trying to reach the site.
So I also just realised, I’m pretty sure that my router being Asus also hosts on the port 80. And now I can’t get into my router to disable the other device to try and test. :smiley:

1 step forwards 2 steps back. :’) Hella fun though.