Cloudflare with Discourse

I use Cloudflare with my Wordpress.

I will use subdomain for Discourse

I have questions about what is the best way to set up “Discourse” with cloudflare.

1 Like

You can put your website behind cloudflare but will work only if you disable the performance through the rules.
I did it and works fine.

So make sure you create a rule to disable the performance other than this making the cloud orange will break your site.

1 Like

What rules do you recommend?

I already tested in digitalocean, but it gave error, I’m looking for how to configure in cloudflare.

This isn’t Cloudflare specific. Your DNS is completely busted.

There is no A DNS entry for forum.meuxbox.com.br.

3 Likes

I installed with a click on digitalocean, but it gave error

I’m looking for a solution here to get started

The installation method isn’t the problem here. The address forum.meuxbox.com.br simply doesn’t exist.

Access your domain meuxbox.com.br on Cloudflare and make it look like this:

2 Likes

Cloudflare

Installation

DigitalOcean

Error http://forum.meuxbox.com.br

How was Discourse installed on this droplet?

I did a one-click installation, I also did the normal installation.

I always get the same error.

app yml

I can’t speak to the one-click install, as we don’t manage that. As for the normal installation, what error did you receive? The screenshot shows your hostname listed, that’s not an error.

‘Discourse’ is working, but not with cloudflare.
I’m looking for a way to do work with cloudflare

I will do a normal installation on VPS VULTR. but we have the same mistake as digitalocean with one click

Get confused about it.

Please do the following:

  1. Create a new VULTR VPS.
  2. Create a DNS-only (grey cloud) A record in Cloudflare that points to your VULTR VPS.
  3. Install Discourse on VULTR following discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub.
    1. Please save the output of ./discourse-setup somewhere so we can review it if needed.
  4. Check that your site loads. If not, share the output of ./discourse-setup, making sure to remove any credentials from it.

Don’t manually modify your app.yml! We need to make sure Discourse is working before you start playing with other templates.

4 Likes

Ok, I’ll do it, tomorrow I warn you.

Thanks. Happy New Year

1 Like

Discourse not coming up may be related to the recent maxmind change. The bitnami image is also not working so there is a strong chance that digital ocean one click might also not have the same temporary workaround.

3 Likes

I did a one-click installation on digitalocean, after installing on normal vultr, i get the same error but i will do the install again to try to find solutions

installed at VULTR

Cloudflare

Error forum.meuxbox.com.br

1 Like

I don’t understand why but Your server is not replying to pings. Are you behind some sort of firewall that is blocking connections to Your server?

I had 100% packet loss for 104.207.144.153

PING 104.207.144.153 (104.207.144.153) 56(84) bytes of data.

--- 104.207.144.153 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2034ms
2 Likes

Did you using LetEncrypt for your Discourse instance? Try to change the Cloudflare SSL/TLS encryption mode, if i remember correct.

That is only applicable if You have cloudflare proxy enabled. In DNS only mode, cloudflare ssl has no impact on discourse

2 Likes