Container fails to (re)start after system update


#1

Hi,

I upgraded my server (debian 8.5) a few days ago via apt-get. docker-engine was updated. I use docker only for discourse. The discourse container did not restart after updating. Manually restarting fails with

/var/discourse# ./launcher restart app
/usr/bin/docker: Error response from daemon: rpc error: code = 2 desc = “shim error: invalid argument”.
Your Docker installation is not working correctly

See: Docker error on Bootstrap

The link provided does not help or I don’t understand. I found some threads around here and tried

/var/discourse# git pull
./launcher rebuild app

but this failed with the same result.

Thanks for any help on how to fix or debug this.


(Jeff Atwood) #2

What does docker version and docker info report? Docker needs to be installed, ideally updated to latest, and working.


#3

docker version

 Client:
 Version:      1.11.2
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   b9f10c9
 Built:        Wed Jun  1 21:23:39 2016
 OS/Arch:      linux/amd64

Server:
 Version:      1.11.2
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   b9f10c9
 Built:        Wed Jun  1 21:23:39 2016
 OS/Arch:      linux/amd64

docker info

Containers: 2
 Running: 0
 Paused: 0
 Stopped: 2
Images: 27
Server Version: 1.11.2
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 38
 Dirperm1 Supported: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge null host
Kernel Version: 3.2.0-4-amd64
Operating System: Debian GNU/Linux 8 (jessie)
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 997.1 MiB
Name: vadmin1234
ID: Tdontknowifthisshouldbeprivate
Docker Root Dir: /var/lib/docker
Debug mode (client): false
Debug mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support

(Jeff Atwood) #4

Hmm, not sure. That looks roughly correct, but clearly something is not right with your Docker. Maybe remove Docker and re-install?


#5

did not help. same issue :frowning:


(Jeff Atwood) #6

Are you on bare metal or some kind of hidden VM? I’ve heard horror stories from being on shared VPSes using certain types of cheap virtualization with Docker… it just doesn’t work.


#7

I am not sure. The server is definetly just a virtual machine but I did not feel any restraints so far and discourse was working nicely for some months now just like some other (non docker) apps, that still work fine.

Meanwhile I also did

rebuild app

again after re installing docker. So now it should be all fresh, or is there anything else I could try to reset (without losing data)?


(Jeff Atwood) #8

Nope, without a functioning Docker you are pretty hosed.