Creating new tags issue


#1

I’m not able to create new tags recently, I get redirected to a tags page showing the few that have been created previously with the heading
Oops! That page doesn’t exist or is private
This happens if I try to create a new tag in a topic and also in the tags group page when I tried following the tagging how-to.

If I add an existing tag to a new topic I get immediately taken to the topics summary page for that tag as though I’d selected the filter from the ribbon.

I believe I’m on 1.6, on a discoursehosting instance…(how do I check, “about” is usually where I’d look to check versioning?)


Mobile : Post Amend / Tag Selection
(Neil Lalonde) #2

If you inspect the page source, you’ll see a meta tag in the head with something like:

<meta name="generator" content="Discourse 1.6.3" ... >

Are you an admin on the site? If so, what are your tag settings? Especially “min trust to create tag” and others like that.


#3

Thanks Neil, mighty quick response time here!
1.6.6
Yes I’m admin.
The only thing I think I’ve changed recently is adding some images for category logo and background. Tags were working ok prior to that.
I’ve just gone through and binned the images to rule that out, although the logo images are gone, the category background images are still displaying.


#4

Any further advice on this please? I’m waiting to roll this out to the rest of the team and am reluctant to do so when it’s not functioning correctly.
I’m back to a plain theme now with no added images and still have the issue.


#5

Have you tried ./launcher rebuild app in console?

I had something similar last night and this sorted it for me.


(Neil Lalonde) #6

There have been a few bugs fixes in the 1.7 beta branch, but what you describe doesn’t sound like anything I fixed. Can you send me a link to your site so I can have a look?


(Richard - DiscourseHosting.com) #7

We’re awaiting our invite to your forum so we can investigate further.

In the meanwhile we’ve looked at your recent changes and you also changed tag_style to box and max_tag_search_results to 20. Maybe this helps…


#8

Thanks Richard,
Invite sent. Yes I tried a few things after browsing the meta for similar issues before raising a ticket.


#9

Ok, problem identified. Unfortunately it’s a PEBKAC issue, or to be more exact touchscreen. I’ve been creating the new tag and then poking the newly created tag on screen instead of hitting CR.
The issue still arises if I try and select an existing tag with finger but I can live with that for now.
Thanks for the help guys


(Jeff Atwood) #10