Tagging not working with latest update


(Niv Shah) #1

This might turn into a bug report, but I am open to the possibility of user error:

I have just updated to the latest version of Discourse, v1.9.0.beta9 +20. I have the following plugins:

I added a new topic, and when I tried to tag the topic, I had the following behavior:

  1. Any tag I typed in that is already in use on the site had a ‘no results found’
  2. These existing tags would not stay in the tag field
  3. Any new tags I made up would stay in the tag field, but not save when I clicked “save post”

So, I’m not sure if something changed that I’m unaware of, but currently my Discourse doesn’t seem to allow tagging of posts.


(Niv Shah) #2

To add some flavor to my previous post, we have a ‘faq’ tag:

We do not have a gobbledygook tag:

I can add the gobbledygook tag and not the faq tag by pressing enter at the end of typing the string:

Once I click the checkbox, the topic does not get tagged, even with ‘gobbledygook’

^^ No tags.


(Jeff Atwood) #3

Can you repro this @jomaxro?


(Niv Shah) #5

I’ve updated to v1.9.0.beta10 +5 and disabled and re-enabled the tagging system and still having this issue.


(Neil Lalonde) #6

Can you give us more info about how you setup tags? Did you define any “staff tags” in Admin > Settings > Tags? Have you restricted some tags to only be allowed in some categories?


(Niv Shah) #7

We have one staff tag. I’ve tried to take a screenshot of all our tag settings


(Niv Shah) #9

Since there hasn’t been a lot of other chatter around tagging, it looks like this is specific to my Discourse instance. Any ideas on things I can try to get tagging to work again? I have attempted to rebuild the app but I’m stilling seeing the behavior described above. I don’t see anything relevant in the logs.


(Neil Lalonde) #10

Do you happen to still have the discourse-tagging plugin installed?


(Niv Shah) #11

I took a screenshot of my installed plugins in the parent post. I double-checked just now, and it doesn’t look like I have that plugin installed, but maybe one of the other ones I do have installed is relevant?


(Neil Lalonde) #12

Hmm. I wasn’t able to reproduce the problem. @jomaxro said he was going to try.


(Joshua Rosenfeld) #13

Apologies for not posting. I set up a Discourse instance with the exact plugins listed, also not able to repro this.

Just to double check, tagging enabled didn’t get accidentally unchecked in site settings, right?


(Niv Shah) #14

That is correct - the tags text box appears when I start a new topic or edit a topic headline. This isn’t true when I disable tagging.

I have just now been able to add the ‘updates’ tag to a topic:

  1. I click the edit pencil
    Dropbox - Screenshot 2017-09-25 12.09.04.png

  2. I click on the “choose optional tags for this topic” text box and see the ‘updates’ tag as the only tag that appears
    Dropbox - Screenshot 2017-09-25 12.09.28.png

  3. If I click that tag, it is applied properly, but anything else I type into that box doesn’t show up as relayed earlier
    Dropbox - Screenshot 2017-09-25 12.10.18.png
    Dropbox - Screenshot 2017-09-25 12.10.27.png

This is a tricky one! I appreciate y’all looking into it.

UPDATE: Is there any way to manage topic tags? I don’t know enough about how tagging works but my spidey-sense tells me there is a tag that is in some way ‘corrupted’.


(Joshua Rosenfeld) #15

If you visit the tags page /tags you can apply bulk edits to existing tags like rename and delete. Is that what you’re looking for?


(Mittineague) #16

I haven’t looked into it much, but I’m wondering if “tag groups” or category “allowed tags” are involved here.


(Niv Shah) #17

Maybe! The fact that only one tag seems to ‘work’ right now just seems off, because I know my users love haphazardly tagging things.

The set of tags lives here:

There are a ton of tags, here is a sample:

The tags AJAX endpoint only bringing back ‘updates’ when there are this many tags? Something seems up there…


(Niv Shah) #18

Is it expected behavior that if there is a tag for a specific category, then no other tags may be applied to that category? Because if so I think @Mittineague nailed it.

UPDATE Yeah jeesh that took me a long time to find that. Ok thank you everyone, I am officially the worst :slight_smile:


(Joshua Rosenfeld) #19

Whoo!!! Glad you figured that out. Thanks @Mittineague! Closing this as not a bug.


(Joshua Rosenfeld) #20

This topic was automatically closed after 5 hours. New replies are no longer allowed.