Customize Text only works for some elements on the Site

I am experiencing a Bug where I tried to customize text on the Dashboard but it only appears in some places on the Site but I’m not experiencing changes within the Dashboard.

Where is says Suspended it is supposed to say Banned.

This is supposed to say Banned? as well.

However, it shows the correct text below in the Dashboard.


It’s highly improbable that this is a bug.

I believe that’s because there are many strings that you need to update and that you missed some. You can have a look here to see that you found them all: discourse/client.en.yml at main · discourse/discourse · GitHub

Also, you need to do a hard reload in your browser after updating those text strings. So that might be the issue.

Thanks for reporting this issue. It actually is a :bug: :wink: and here’s a fix for it:


Shows that I know! That was a quick fix!

1 Like

Can you explain how to add this to my site?

Nothing special need, just rebuild your container or update from the web ui and try again. I just merged the change.

How do I rebuild the container? Do I run the command to rebuild my site?

Run the following commands

sudo -s
cd /var/discourse
./launcher rebuild app

or access with your browser and then click Upgrade all on the right top.


Sorry for being That Guy™, but there’s a typo in one of those;


No, that’s not a Typo. I wanted it to be that way.

1 Like

Thanks, I updated my Site and it is working perfectly. Thanks for adding the update file to my site!


This topic was automatically closed after 21 hours. New replies are no longer allowed.