Dark Theme Not Applied After Wizard Update


(Bali Bebas!) #1

After running the /wizard and selecting the Dark theme my users are still seeing the light theme. User profile settings show two “Dark” options listed (only one of them changes the theme). Users who had default interface color setting are not seeing the dark theme once activated—they still see the light theme.

I’m running 2.0.0-beta9 after recently updating from beta7 (from which my site was created).


(Jeff Atwood) #2

Can you repro this @jomaxro?


(Bali Bebas!) #4

If it’s not easy to repro just LMK and I can try a back-up and restore on my end. I’m still relatively early in the audience building process so now would be a good time for me to make some mistakes.

Thanks for all you do. Jeff is the guy who got me using WTFPL for my software. :smiley:


(Joshua Rosenfeld) #5

Hi @balibebas, I was not able to reproduce this, no. Here’re the steps I followed:

  1. Created a brand new site.
  2. Logged into site as Admin (user A)
  3. Skipped initial setup wizard
  4. Created a new account as a standard user (user B)
  5. Both user A and user B had the default (light theme) set.
  6. Checked theme settings as user A and saw that Default was set as enabled by default
  7. Ran wizard as user A via /wizard. Left all values as default (entered fake info when required), and set theme to dark.
  8. Checked theme settings as user A and saw that Dark was set as enabled by default
  9. Refreshed site as user B and saw dark theme

I’ll also note that there is only 1 dark entry in the theme dropdown for user B.


(Bali Bebas!) #6

Thanks for trying @jomaxro, think we can just assume I hit some corner case somewhere. Looking over the steps you provided the only difference I see might be running the wizard several times and switching back and forth as if the user wasn’t sure what they wanted. Whatever it was hopefully it’ll just vanish as the custom themes code bakes. Cheers and thanks again.