Dashboard empty since upgradeto 2.5.0

Since the update to 2.5.0, our dashboard does not display any graph at all. The settings of dashboard are set to default with the usual page_view_total_reqs, visits etc.
I see no error in the JS console nor the Error Logs.
Is there something new to activate?

1 Like

Silly question to ask, but have you cleared the cache in your web browser since the upgrade? Which browser are you using? And is that the only page that is not working?

1 Like

Is that for one staff user, or all?

Are you using a supported browser?

There have been similar issues in the past using browsers such as Brave when device recognition (fingerprinting) is turned on.

2 Likes

Yes, I even tried different browsers: Firefox and Chrome.

I use Firefox 77.0.1

It is at least happening to 3 different users.

Have you tried in safe mode?

1 Like

How do you activate the safe mode?

Please see

2 Likes

I tried in safe mode and I got the same result: no graph.

Have you tried disabling all third party plugins? That’d be the next step. We have no repro of this problem anywhere on our hosting.

With all plugins disabled, still no graph.

I’m not sure. We have no repro on any of our instances, but we run the latest beta. You could try updating to latest beta, which is how all our hosted customers run.

1 Like

We do not want to run on beta because we prefer low maintenance and stability.
Do you have any idea where to look at? Because I can not find any error logged.

That perception is what makes those three release names so problematic.

The vast majority of sites run on tests-passed. There are far fewer sites on beta and stable. A lot of developer focus is on the tests-passed builds, with fixes arriving in hours rather than days. If the other releases are also affected, those fixes are only subsequently backported, and even then not always.

That’s before you dig into the other issues faced by stable, third-party plugins are a particularly good example as they’re usually updated to support tests-passed and occasionally break compatibility with stable in the process.

2 Likes

After doing a full rebuild with ./launcher rebuild app, the dashboard is back.

2 Likes