Labels broken in the Consolidate Pageviews graph

Tha’s what I see at hosted with Discourse:

1 Like

Does that occur in safe mode? Can’t reproduce on our self hosted forum.

1 Like

Not even sure if I can turn on the “safe mode” for a site hosted with

I tried it, and after navigating to the admin console, the URL is:

Same issues in graphs:

Hey @meglio :slight_smile:

Could you check it again now and see if it’s looking better for you?

1 Like

@JammyDodger unfortunately no, just checked now.
My browser is Brave if it makes any difference.

I tried multiple browsers, but I can’t seem to be able to reproduce it. :thinking:

Does it happen in other browsers as well?

Have you tried in Brave?

I’ve just given Brave a try, and I can’t repro on my test site.

Do you have any browser extensions that may be playing a part?

1 Like

I am not sure it’s relevant or not but I’ve read before a few article about the Brave Shield can broke the canvas.

1 Like

Yes, and with the Shield on (as stated by Don, it might be relevant in your case)

I tried opening it in a brand new Guest profile in Brave, supposedly one that does not have any 3rd party plugins, and have the default settings. Labels are working as expected.

Now, I only have these 2 extensions enabled: Bitwarde and React Developer Tools. I have no idea why/how any of them can interefere with the rendering of labels.

However, to even bigger suprise, turning them off and reloading Discourse did not help either.

Next, I went through all these plugins and turned them off/on one by one to see if it affects the rendering. Nothing, the issue persists.

At this point I have run out of ideas. How do we investigate it further?

If you turn off the

Does that have any effect?

oh, I misinterpreted the messages above. I thought someone tried it and it was fine either way. So I haven’t even tried it.

Now that I tried it, I can tell it does break the rendering. As soon as I turn the Shield off, it renders okay.