Dashboard not displaying in Brave, due to fingerprint protection being enabled

When viewing the Dashboard in Brave I’m seeing a few cosmetic issues that are making it difficult to read:

Specifically the tool tip and the values below the graphs. Can someone confirm this?

I don’t think that we officially support Brave.


Can’t confirm. Looks good in my Brave browser.


Bump. I still can’t see reports. :frowning: If someone has a chance take a look at the reports page in Brave.

I think Brave uses Chrome.

@Krischan I have shields up for device recognition.

With all the privacy abuse going on I don’t support device recognition. Not until the ad industry takes responsibility of user data.

Brave isn’t supported. Unless you can repro the issue with a supported configuration there isn’t really anything to do here.

Have you tried disabling all your plugins, we are unable to repro, we host the brave forums and the admins there never complained about this

1 Like

Tried to repro, works fine for me with the same options you’ve shown here.


@Krischan That’s good that it works for you I guess.

I’m on Mac OS X.
Brave Version 1.0.1.

@sam It says I have two plugins but no option to disable them. I’m guessing I don’t have permissions.

I’ll see if I can get test it without plugins

Talking about brave plugins here :slight_smile:


lol no problem. none installed:

I know that iOS/iPadOS 13 is not the same as macOS but I’m having no problems running as admin using Brave on latest.

By the way, Brave is based on Chromium not Chrome. So it is not close to a supported browser but is quite minimal so I haven’t had any unusual interactions.

1 Like

Chromium is very close to a supported browser. It is built on Blink and the same rendering engine Chrome uses and v8.

I have all 3 installed on my desktop and all 3 work just fine displaying admin reports.

@vel can you confirm you are running:

[Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) unknown (64-bit)](https://brave.com/latest/)


Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)

If it helps, I checked the console to see if there’s any errors going on there and there’s this:

1 Like

Are shields up when you test in Brave? Brave blocks ads, upgrades to https and blocks device recognition attempts.

It looks like the setTimeout might be from the PWA service worker:

Fingerprint protection is not enabled by default. It gives me grief so try turning it off.


That’s it.

With device recognition off the dashboard displays correctly.
With device recognition on the dashboard shows what is shown at the top of the page.

1 Like

Fingerprinting Protection Mode · brave/browser-laptop Wiki · GitHub
Because most browser fingerprinting defense requires disabling web features that are required for many sites to work properly, it is implemented as off-by-default for now (can be turned on in about:preferences globally, or on a per-site basis in the Bravery panel).