Install fails with port 80,443 on GCP

Hi,

I created a VM with GCP compute engine. My domain name is solarnauts.net (from Namecheap)
I have created a DNS A-record, for the host I have put the subdomain discourse.solarnauts.net and for the value, the external IP of my VM.

When I run ./discourse-setup, I get the port 80 and 443 warnings (see down below).
Despite add a firewall rule to my VM opening these 2 ports, i still get this error. What do you advise?

Thanks

Checking your domain name . . .WARNING: Port 443 of computer does not appear to be accessible using hostname: discourse.solarnauts.net.WARNING: Connection to [http://discourse.solarnauts.net](http://discourse.solarnauts.net/) (port 80) also fails.This suggests that discourse.solarnauts.net resolves to some IP address that does not reach this machine where you are installing discourse.The first thing to do is confirm that discourse.solarnauts.net resolves to the IP address of this server.You usually do this at the same place you purchased the domain.If you are sure that the IP address resolves correctly, it could be a firewall issue.A web search for "open ports YOUR CLOUD SERVICE" might help.

1 Like

Try running
netstat -alpn | grep 80
on your gcp to find out if a webserver is already running on port 80

there might be a little latency for the DNS record to propagate ?

Did you open 80 and 443?

How much time does this typically take? I bought the domain 2 days ago and added the A-record yesterday. Any way to find out if it has propagated?

E.g. i tried this:

$ nslookup solarnauts.net
Server:         8.8.8.8
Address:        8.8.8.8#53

Non-authoritative answer:
Name:   solarnauts.net
Address: 192.64.119.14

$ nslookup discourse.solarnauts.net
Server:         8.8.8.8
Address:        8.8.8.8#53

** server can't find discourse.solarnauts.net: NXDOMAIN

For some reason, Your DNS records may not have been created properly. I still see namecheap parking dns records and nothing else on your domain solarnauts.net

2 Likes

I created a firewall rule in GCP engine that opens both ports but I read there could be things more specific to container-optimized OS relating to Docker itself.

1 Like

How did you check this?

through a few online tools e.g.:
whatsmydns.net
dnschecker.org

1 Like

I tried with nslookup (see my earlier response to @Benjamin_D), is that doing the same check?

nslookup is a local check from your own system, it can be influenced by a lot of factors including your system & router’s dns cache and your ISP’s dns resolver. that’s why I resorted to a 3rd party which checks through multiple PoPs to confirm if a dns records exists and what value it returns.

Ok, so that means the problem is, for now not related to the firewall and i should look into Namecheap where i created the A-record? maybe it’s just a matter of waiting a bit longer? I created it less than 24 hours ago. Is that typical to need to wait longer?

1 Like

Newly created dns records usually start resolving in about 10 minutes. slower resolvers can take around 2-6 hours and in worst cases, 48 hours is the maximum it should take. I don’t have any prior experience with namecheap so I can’t really speak for them but most registrars’ dns propagators start resolving fairly quickly.

The thing that’s oddly suspicious about your setup is that there seems to be no change in the dns records anywhere so maybe your records weren’t created properly.

2 Likes

@itsbhanusharma you nailed it.

On Namecheap, the “host” field, i entered the full address ‘discourse.solarnauts.net’ instead of just ‘discourse’.

And so i tested your dns checker with:
discourse.solarnauts.net.solarnauts.net’, that one is fully propagated.

So i guess i just have to replace the host field by just ‘discourse’?..

3 Likes

Yes, that should do the trick.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.