Digital Ocean 1-click install tries to reinstall itself every time I connect


#1

Every time I try to connect through PuTTy to my DigitalOcean Ubuntu 16.04 x64 droplet to connect to the terminal, it prompts me, in a way I cannot escape, to reinstall Discourse. Since it’s all installed nothing happens and my settings and users are all there, but it’s very annoying and eating up processing power.

It’s the same prompt as the initial startup when you choose the preconfigured Discourse droplet on DigitalOcean. It prompts the email address to use, username and password, mail server API key, etc etc. How do I disable this?


(Matt Palmer) #2

This is using the DigitalOcean “one click” installer, right, not the official installation instructions? If so, there have been previous discussions about this here, but ultimately you probably want to contact DigitalOcean support, as they were the ones who setup their install in this weird way, and it’d be helpful to them if they knew how much confusion their design was creating.


#3

Yup, this is what I see every time. Just spamming enter and letting it go through yields no data loss or hiccup in performance from the end user’s side, but takes about 30 seconds for my particular droplet speed before I can actually do anything from the terminal.

I’ll contact DigitalOcean support and see what they have to say. Thank you!


(Joshua Rosenfeld) #4

A faster method than spamming enter would be to type Ctrl + c to exit the script.


#5

That helps a lot, now I just need to find a way to disable/delete this script. Thanks!


#6

i would advice creating a user and logging with SSH Key, its good way to avoid that (Also safer) :wink:


#7

did anybody find a way to remove the script?


#8

Check ~/.bashrc and comment out /var/lib/digitalocean/discourse.sh to #/var/lib/digitalocean/discourse.sh. You can probably do this with nano or FTP editing.

If not immediate, a reload should stop that line from being loaded and the script should stop.


Problems after updating docker