Noob installation : email not working, trouble with the digitalocean console

First of all, i’m an autodidact newbie.

So I just installed discourse using Digitalocean and PuTTY,

Everything is fine but I don’t receive the register email.

I tried to follow these steps : Troubleshooting email on a new Discourse install

But i have an issue.

I’m using PuTTY to access the console and no command seems to work.
It’s always telling me the following :

root@testdiscourse:~# ./discourse-doctor
-bash: ./discourse-doctor: No such file or directory

So I tried using the console on DigitalOcean but I can’t log, i get this message :

Droplet Console

Use the Droplet Console for native-like terminal access to your Droplet from your browser. Here is the list of supported OSes for the new console.

To enable the Droplet Console, log in to your Droplet as root or as a user with sudo access. Once connected, download and execute the agent installation script with the following command to enable the console immediately:

wget -qO- | sudo bash

I don’t understand were I have to enter this command, and I’m kind of lost on why it doesn’t work.

Should I not use PuTTY ?
How do I connect using the console of DigitalOcean ?

Try to give first:

cd /var/discourse

And after that ./discourse-doctor

I’m almost sure your email-issue is because you have not installed any service for email delivering.

There is quite lot of things you have to setup on droplet. One-click installing for VPS and Discourse is just starting point.

Console of droplet is just for emergency situation, when PuTTY or something else breaks. But login using PuTTY and give then

wget -qO- | sudo bash

It doesn’t matter where in all directories you are at that point.

1 Like

Thank you Jakke for the answer !

The commands worked, that’s a first !

I have an email service and set the SMTP port and everything.

Apparently I have an issue with the invalid login or password issue. I’m gonna look into that.

Thank you again

Ok so there was a typo on de password and i changed it.

Now I have another issue :

Email address for mail test? ('n' to skip) []:
Sending mail to . .
Testing sending to using, with plain auth.
SMTP server connection successful.
Sending to . .
Mail was not sent.

Reason: 550 5.7.1 Sender mismatch

My login and password is now alright but I can’t find the issue

Shortly, but not easily: This error message means the email was rejected either because of security policies or incorrect configuration on the recipient side.

That means the server has blocked your email for example because it doesn’t recognize email address of sender. There is some other reasons too.

1 Like

And one that leaves you not knowing how to the the most basic things. This is why the standard install is recommended…

The problems you’re have with their console suggest that they haven’t updated the base image, as new Ubuntu installs “just work” with the new web based console, another way that the one click hurts people. That said, if you can log in with putty then you don’t need the web console.

“sender mismatch” sounds like you need to run discourse-setup which will let you set the notification email address. Another way would be to create an admin account with

 ./launcher enter app
 rake admin:create

And then change notification email in site settings.