Disable dark screen with avatar spotlight for new users

faq-material

(Jay Pfaffman) #1

I have a client who thinks their users will be confused by the darkened screen that new users get when they first get logged in. Is there a setting to change that behavior? (I’ve searched here and settings things like “disable” “new user” and so on to no avail). If not, is there a way to convince this person that it’s not necessary?


(Sam Saffron) #2

Wait, didn’t we add text to that as well? Sure it was confusing when screen was just darkened but it practically has an arrow saying click here when it pops up these days.

Can you post a screenshot of what this client finds confusing?


(Jay Pfaffman) #3

But, really, it goes away after they click it once. It doesn’t seem so confusing to me.

Perhaps what they should do is customize that first message in system_messages.usage_tips.text_body_template


(David Baker) #4

It works well in the normal Discourse sign-up flow: I am new to the site, I have to click Sign-up and then complete the few fields - then I get this nice ‘arrow’ to help me get started in a place I’ve never been. It is a nice gradual welcome to a new web space.

But in an SSO context it’s not the same: I start my experience in another web space. I click Sign up there and go through that tool’s set of screens and experiences. Then I need to land on the ‘sso-integrated’ Discourse space (after perceiving that I am now successfully in a new web space already) and (first hit) I have to manually click (log-in) in order to ‘engage’ the sso connection. But rather than a gradual sign-up step (it already happened in the SSO host tool) I am (second hit) struck by a sudden darkening of my screen. I can safely get out (by following that arrow) but, in this context, an innovative UI experience is now a jarring one.

Might there not be a setting like “Disable starting spotlight screen in SSO setups”?