Discobot can't communicate with me

I’m trying to use Discobot on my own forum. For some bizarre reason, I never got the Greetings! message from Discobot, and when I mention or message it, I don’t get a response. The Admin got the message and Discobot would respond to him. Do I need special permissions to communicate with Discobot?

I tried running commands like
@discobot display help
(Mentioning it was intentional here) but I got no response on my own site.

See??? Nothing! What happened?

Edit: I never got the intro message here, either. I did get it on the Ubuntu forums, though.

Try that in a private message :). It may be a bit shy in public :wink:

1 Like

No… it didn’t work in a PM on my forum and it doesn’t appear to work here. It should pop up almost instantly, right?

works for me:

I still get no response :frowning:
I’ve tried help and starting both tutorials… nothing!

I also don’t know why I haven’t seen the greeting message. Is there an issue with my accounts?

1 Like

That’s odd. Can you please check one more time? You might have moved it to your archive folder.


Can you try the following in a PM with discobot as a participant:

  • Start a PM and mention:

@discobot start advanced tutorial

See if you then get a response. Works fine for me too.

Actually, you can just mention it here and it will automatically message you with the advanced tutorial.


@discobot display help

I currently know how to do the following things:

@discobot start {name-of-tutorial}

Starts an interactive tutorial just for you, in a personal message. {name-of-tutorial} can be one of: tutorial, advanced tutorial.

@discobot roll 2d6

:game_die: 3, 6

@discobot quote

:left_speech_bubble: In all chaos there is a cosmos, in all disorder a secret order. — Carl Jung

@discobot fortune

:crystal_ball: You may rely on it

1 Like

Works again! Thank you , mate! :eyes:

I signed up here a few days ago and I never got the message… If you read the first post, I mentioned discobot and I got nothing. I also tried PMing discobot and I never got anything.

This is a problem here and on my own forums, but not on the Ubuntu forums…

@discobot display help

1 Like

Did you click skip the tutorial when you first logged in? If so, that turns off Discobot’s new user tutorial functionality IIRC.

5 Likes

Yes, I did click skip. Should that impact me being able to use discobot at all?

1 Like

In your preferences -> interface you can change this. After that it should work fine.

9 Likes

I didn’t see that option the first time. After unchecking it, I can now message discobot.

@discobot display help works :slight_smile:

3 Likes

Thank you for pointing this out.

I’m a moderator on a forum where users have been reporting discobot ignoring them for awhile now and we couldn’t figure out what was causing it. So far everyone who reported the issue did indeed skip the tutorial. I never would have thought to check that setting if it wasn’t for this thread. :slight_smile:

5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.