New user unable to send a message to discobot

Hello, I’m testing out our new user onboarding and have encountered a problem.

As a new user I’m not able to send a message to our discobot (renamed hubbot)

Users used to be able to click on the following link and start the tutorial but it no longer works.,%20I%27m%20ready%20to%20start%20my%20new%20user%20tutorial!&body=Directions:%20Just%20click%20the%20blue%20%60Message%60%20button%20below%20to%20tell%20@hubbot%20start%20tutorial

I also cannot respond directly to the Hub Bot welcome message.

How did you rename discobot and the message in the screenshot what prompts it to be sent? When a user accepts an invite?

1 Like

I followed these directions to rename and update welcome message

Yes, new users get the message when they sign up and log in for the first time.

I am able to use the link I shared and send a message to discobot when I’m on my staff account but I cannot when I’m on my new user account.

I suspect the public profile of Hub Bot is (for unknown reason, now) hidden (in Preferences/Interface).

Here are Hub Bot’s Interface Preferences

I noticed that I get a warning on their profile but am not sure how to figure out what that warning is about.

that would have been too easy… :pleading_face:
:thinking: I tried the route new-message with a tl1 user and it worked once I made discobot’s profile public, but I’ve left out the message body… so it seems the quote %60 around Message are not allowed.

What are the notifications preferences of Hub Bot? Are the PM allowed?
or maybe… auto close messages post count isn’t set to 1 by any chance? :sweat_smile:

Hello in your preferences > Interface is skip new user onboarding tips and badges checked? This is a very common reason why users cannot message discobot.

Nope, it’s unchecked for the new user.

I’m thinking Hub Bot isn’t allowed to not have PMs, right? Here’s its interface settings.

Its notification settings

Where is this setting?

Sorry, I’m not exactly sure what you mean by this. Could you explain more?

it’s there:

In 2.7.0.beta1 ( ee9ea20d95 ) there is another parameter for private messages :thinking:

Could you try this link:,%20I%27m%20ready%20to%20start%20my%20new%20user%20tutorial!&body=Directions:%20Just%20click%20the%20blue%20Message%20button%20below%20to%20tell%20@hubbot%20start%20tutorial

1 Like

Whoa! I reset it because it was currently 0. Why? How did that happen?

Hmm… I’m on that version right now.

That still didn’t work for my new user. I get this message.

I don’t see the ability to message hubbot on their profile either.

About the notifications preferences, that’s what I get:

In my setup these two parameters are checked:

  • enable personal messages
  • enable system message replies

Yeah, that setting doesn’t show up anywhere on our hubbot page.


I think you may have hit on something. So, I have

  • enable personal messages disabled
  • min trust to send messages 3 but
  • enable system message replies enabled

Does discobot not fall under system messages?

:thinking: hum… staff yes, system maybe not, system is another user

@osioke Maybe you would know for sure?

In my mind, the enable system message replies setting should also allow for messaging discobot, not just system.

1 Like

This might be the cause. Have you tried enabling this?

1 Like

enable system message replies
I’m not even sure in what case someone would reply to system :thinking:?
Is the admin suppose to monitor the system PMs?

edit: discobot (and group messages apparently) are system messages, so that’s (at least partially) why

My new user can now send a message to discobot when I did both of the following

  • enable personal messages enabled
  • min trust to send message 1

However, my question now is that I need personal messages disabled AND new users to be able to go through the discobot tutorial. :rofl:

Discobot is basically in the same line of system, I think. Basically everyone should be able to do its tutorial, right? Regardless of if they can generally send messages?