DiscoTOC option missing from gear icon menu

Updated yesterday, and now today we see the DiscoTOC icon missing form the Post Cog.

So can’t build a TOC.

2.9.0.beta10 [99d9c933c6]

Any ideas beyond doing a rebuild?

1 Like

Update - Did a rebuild some hours later that evening.

This made no difference, still no sign of the option in the post cog.

1 Like

I’ve just had a quick run-through on my test site and it appears to be working okay on there:

Forgive me for the basics, but just to check :slight_smile:, have you enabled it for the theme? And are you using it in the first post of a topic?


Yes and yes.

My original test post with DiscoTOC is still there and works.

So I have had it work in the past.


There’s a setting for minimum trust level to create TOC which might be worth a check? Other than that I am unsure. If it’s not that we can split this off into a #support topic to get more eyes on it. :+1:

Do you have any other theme components/customisations/anything else unusual that may be affecting it in some way?

1 Like

As Admin I’m always above the level and it wasn’t changed since installation of the component.

I’ve deleted a few recent components to pair back to what it was like when DiscoTOC was installed, if that doesn’t work, I can only suggest something broke in an update.

1 Like

I thought that might have been a long shot. :slight_smile: I’m not sure why it’s missing from your setup. It’s working on my test site, as well as here on Meta and Try.

Could you try deleting and reinstalling it and see if that helps?

Or perhaps it’s device-related - could you try it on something else?

1 Like

Right, I deleted the component. Then reinstalled the component.

  • Still no option in post cog
  • previous DiscoTOC test post does not utilise the feature.

This worked after I realised I had forgotten to re-add to theme!

The old turn it off, turn on solution… why didn’t I think of that! :laughing:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.