Discourse comments aren't showing on latest page


I’m encountering a strange issue and I’m not sure what is going on.

Once I’ve linked one of my comic pages to the Discourse topic, the Discourse comments have shown up consistently. But for some strange reason, it’s not doing that on the current page:

This is the Discourse topic:

I feel like I’m doing the exact same thing I’ve done on the dozens of previous pages I’ve posted:


And I’ve tried unliking and relinking, but the Discourse comments aren’t showing up on this page. (But they are still showing, and I think still updating, on the previous pages.)

User error is always a likely possibility. Any guesses what I might be screwing up here?

Any help would be greatly appreciated. Thanks!

This sounds somewhat similar to an issue I had where the comment count was showing an incorrect number of comments (sometimes zero). We don’t display the actual comments. In your case, the count is showing as 9, but none are showing.

It doesn’t look like user error. I see the “Comments are not available” template being displayed below the post. Can you go to the post’s edit screen on WordPress and enable Custom Fields? If you’re using the new Block Editor, custom fields are enabled by clicking the ‘options’ link in the sidebar.

Let me know if values have been set for both the discourse_comments_raw and discourse_permalink custom fields.


Thank you for the quick and helpful response, Simon. Here is what I’m seeing in my Custom Fields for that page (I don’t think I see a discourse_comments_raw field, though)

Please let me know if you need anything else.

1 Like

Thanks! I’ll take a look at what is going on with this tomorrow.

1 Like

I am unsure why the discourse_comments_raw post custom field is not getting set for this post. Do you have any posts on your site that have been published to Discourse after this post was published? Can you have a look at the WP Discourse Connection settings tab to make sure you are still seeing the “You are connected to Discourse” notice?

Hey Simon!

Here is what my Connection Setting tab says:

The next page that will be published after the one with the issue will be posted tonight (unlocked, really), so we will see if the issue continues.

I’m not sure if this is a factor or not, but I do something a bit special so my Patrons are able to comment on a locked “Preview Page” in advance without spoiling anything for the general readership. The ability to do this is a big reason why I choose to create a Discourse install.

Here is the procedure I go through. (Which has worked for well over a year now of twice-weekly updates.)

  1. I first post the comic page for my Patrons. It’s locked on my webcomic site. For example, this is the current locked “Preview Page” for my Patrons that I’ll be unlocking for my general readership later on tonight:
  1. At the same time I post that Preview Page, I also use the WP-Discourse plugin to create the connected topic for that page in my Discourse Community in a Patreon-Only category (“Sneak Preview Pages”) by using the Discourse Wordpress metabox.

It is in that Patreon-only category that my Patrons can comment on the Preview Page in advance without any of the general audience seeing their comments at that time.

  1. To make sure that no one in the general audience can see those comments on a Preview Page on my webcomic site, once that Preview Page is posted, I click Unlink Post from Discourse for that Preview Page in the Discourse metabox for that page and Update.

  2. About 3 days later, I unlock the Preview Page to the general public and move the Discourse Topic for that page from the patreon-only Sneak Preview Pages category to the unlocked Page Updates category. At that time, I click Link to Existing Topic in the Discourse meta-box on Wordpress for that page and add the Discourse URL that my Patrons have been using to comment on the page and click Update.

This allows my general audience to now see the comments that Patrons have been making on this page when it was locked. Thus, my Patrons get to have first say on every published page, but nothing was spoiled until the page was unlocked.

The page we are talking about now (Page 29) is the most recently unlocked page on my site. Tonight, we will be unlocking the next page (Page 30).

Hopefully that makes sense… I know it might sound complicated, but this is what I’ve been doing for over a year and it has worked just fine. But I wanted to give you a heads up, on the off chance that it might be a factor.

Please let me know if there is any other way I can help.



1 Like

That is somewhat complicated, but I don’t see where the process would be failing. Let me know what happens when you unlock the next page.

1 Like

I unlocked the next page and the Discourse comments are showing just fine:

But they are still not showing on the previous page…

Not sure what the difference is…

1 Like

It is strange that unlinking and then relinking the post to Discourse doesn’t solve the issue. When a post is unlinked from a Discourse topic, all data that associates the post with Discourse is removed. Can you try unlinking and then relinking the post again? Let me know what happens.

Hey Simon,

I unliked the post and confirmed it was unlinked.

Then relinked it

Cleared all my caches. But I’m still not seeing any Discourse posts.

This is the meta data:

And just for you information, here is the metadata for the next page which is showing the Discourse comments:

Does that help at all? Anything else I should test?

Thanks! Yes, that helps.The discourse_comments_raw metadata should get set when you browse to the page, but that isn’t happening. I’ll try to reproduce the issue.

Are you using any caching plugins on your WordPress site? If so, can you try clearing the cache for that page?

1 Like

Glad that’s helpful. I am using W3TC.

And every time I’ve updated I’ve purged all caches.


And I just did it again now. Not seeing any change, though, unfortunately.

Thank you for your help!



It’s still not clear to my why there is a problem retrieving the comments for this one topic.

Can you check to see if you have enabled the plugin’s Cache Comment HTML option? It’s found near the bottom of the Commenting settings tab. That setting shouldn’t cause the issue, but if it is enabled, try disabling it to simplify things.

Have you enabled the Sync Comment Data setting (found on the Webhooks tab) ? If so, try temporarily disabling that setting and refreshing the page.

If neither of the above fix the issue, can you let me know the values of some of the settings on your Commenting settings tab? The settings that could have an effect are the settings that start with “Max Visible Comments” and end with “Only import moderator liked.” These values are passed to Discourse with the request to fetch comments.

Have you made any changes to the WP Discourse code, or hooked into any of the plugin’s filters through your site’s theme?

1 Like