New comments aren't showing up under post

Hey Simon,

It doesn’t rain, but it pours. I’ve noticed one other thing.

On the public webcomic page (page 33) previous to the Sneak Preview page, even though there are 11 comments under the post on Discourse, for some reason WP-Discourse isn’t adding any new comments to the Wordpress page after comment #4.

I have Maximum Visible Comments set to 300

The page is still linked:


And the metabox seems to recognize that there should be 11 comments:

And on other webcomic pages, WP-Discourse is bringing across more than 4 comments:

But no new comments past comment #4 are showing up under the Wordpress page for page 33.

What should I look for if I’m going to troubleshoot this?

Please let me know. Thanks!

If you add a new comment to the topic that is showing more than 4 comments, does the comment get pulled to WordPress?


They haven’t been. And I just tested it again now.

And even after 15 minutes, it still isn’t showing up under the page.

Since this is the only page that is broken, I highly suspect user error on my part. But for the life of me, I can’t figure out what I did differently on this page. :confused:

Any ideas? Should I just unlink and relink it again?

EDITED TO ADD: Whoops. Sorry. I think I misunderstood your question. On the other pages, the comments are all showing up pretty much immediately. But I’ll test that again right now.

Yep. New comments on the other pages are showing up just fine:


Anything else I should try?

If you go to the posts list on your WordPress dashboard, does it show the number of comments for the post? If so, is it showing 4 comments?

It wouldn’t hurt to try.

This is unrelated to the issue, but if you would like to not have numbers displayed next to the Discourse comments, you could add the following CSS to your theme:

ol.comment-list {
    list-style: none;

This is the default WordPress style for displaying the comment list.

1 Like

Hey Simon,

The post list actually shows the number of Disqus comments, not Discourse comments.

Thank you for that CSS tip. The numbers haven’t really been bugging me, but it might indeed look better without them. When I have time, I’ll give that a look. :slight_smile:

And let me try unlinking and relinking to the Discourse post. I was holding off on doing that in case you needed to troubleshoot it directly, but “cycling the power” has a way of fixing most weird errors. Fingers crossed. :smiley:

Hmm. Unlinking and linking made it worse. :frowning: Now no comments are showing:


Even though the metabox in the Edit Page screen shows that WP-Discourse knows that there should be comments:

I’m baffled. Why is this one page being so difficult?

Can you make sure that the ‘Sync Comment Data’ option is not enabled? It’s found on the Webhook Settings page. That webhook won’t work because it depends on the comments number. The comment numbers on your site are coming from Disqus, not Discourse.

Have you added any custom code to your site that hooks into any of the WP Discourse filters?

1 Like

I haven’t added any custom code to my site that hooks into WP-Discourse filters.

And hmm, that Sync Comment Data option is enabled:

All the other Wordpress pages are updating the Discourse comments fine (even with Disqus comments showing up in the comments number).

If I uncheck this box, will that break my other pages with WP-Discourse and updating in a timely manner?

Will I also need to change something on my Discourse site if I uncheck that box?

It seems possible that the comment number being set by Disqus is interfering with the syncing of Discourse comments. When the Sync Comment Data option is enabled, it checks that the number of comments on WordPress is less than the number of comments on Discourse before syncing the comments. I don’t think this is going to work reliably on your site. I’m not sure that disabling the setting will solve your issue, but it won’t hurt. You can re-enable it at any time.

With the Sync Comment Data option disabled, you will need to wait up to 10 minutes to see new comments. If this does solve the issue for you, you should also disable the webhook you created on Discourse. Don’t do that until you are sure the problem is solved though.


I’ve disabled the Sync Comment Data option, and gave it a full hour. And there are still no Discourse comments showing up on page 33. :frowning:

Anything else we can try?

Can you think of anything dumb I might have done with just this one page that could be causing this?

No, I’m not sure what’s going on with that page. My guess is that it’s a conflict with the Disqus plugin, but I’m not able to test that.

You could try deleting the discourse_last_sync custom field for the post. You can do that by clicking the ‘Delete’ button underneath the custom field entry.

OK. I did that and clicked Update. It doesn’t look like that field has been replaced with a new one.

So far, no Discourse comments have shown up on that page.

If you think it’s a conflict with Disqus, would temporarily disabling the Disqus plugin confirm that?