Discourse's comments aren't displayed on WordPress posts

Hello everyone. :slight_smile:

This is looking to be a relatively common issue, but I didn’t found ant possible solution in the existing posts :

When a comment is posted on the Discourse feed of my News section, it isn’t displayed. It displays a white space instead. As the commentary number rises up, the white zone gets bigger.

The webhooks are already configured in Discourse admin and have positive feedback. The display options in WP-Discourse plugin are configured too, and Jquery auto-load is enabled. This is a brand new site, so the old WP commentaries are disabled.

As there is an added white zone when a comment is posted on Discourse, I think WP tries to display comments, but doesn’t make it for some reasons. This is maybe an issue with CSS files of my actual WP theme. I hope not, as i’m pretty unfamiliar with CSS rules.

Any ideas ? :slight_smile:

Can you share a link to a page that the comments are failing to display on? You can either share it here, or PM it to me.

1 Like

This isn’t more a private site, no problems.
An exemple here : 3 ans après les autres, Sony se met enfin au format Direct avec les State of Play - InfiniDreams

3 comments and no one displayed. Any suggestions ? :slight_smile:

The template that is being used for that post is the template that gets used when no comments have been pulled from Discourse. That template displayes alternet text if there are comments on Discourse, but for some reason none of them are getting pulled to Discourse. That is why the text is different than on this post: Super Mario Maker 2 annoncé pour Juin 2019 - InfiniDreams.

I don’t think the margin at the bottom of 3 ans après les autres, Sony se met enfin au format Direct avec les State of Play - InfiniDreams is caused by the WP Discourse plugin.

Have you changed any settings on the plugins Commenting Settings tab? This group of settings could cause comments to not be displayed:

The most common cause is if the ‘Only Import Moderator Liked’ setting is enabled. It requires posts to be liked by a Discourse moderator, not an admin.


Ok, I see. Need to found why this default template is used.

Only 1 comment is required to pull them on WP, and the Moderator-like option is disabled. All other values are on 0, I want all comments to be displayed. Issue still here. :frowning:

My Comment settings :

Can you try disabling the ‘Cache comment html’ option?

Also, try creating a new comment on the Discourse topic to force the plugin to fetch new comments.

That’s even better : Now I’m unable to just get the forum link on the comment zone when I create a new test post… It’s just says “Comments are not currently available for this post”.

And when I post a Discourse comment linked to this test post, this error text disappers too. There is nothing : No comments, no link and no error mention.

Sorry, but your plugin is totally chinese for me. x)

For notice, the comments number is displayed fine at the top of the posts. So WP seems to know there are comments on Discourse.

Can you try disabling the ‘Sync Comment Data’ webhook? You may need to wait about 10 minutes before the plugin tries to fetch new comments from Discourse.

Link Problem fixed after disable / re-enable the webhook. But now I’ve still have trouble to display comments on WP. Back to the beginning.

I think I’ve tried absolutely everything. Publish with admin account, publish with author account, forced Discourse publish enabled, then disabled. Default category, custom category, posting comment as admin, posting comment as user, enable / disable HTML cache, enable / disable Ajax auto-load…

That’s probably a local issue on my server setup. I’ll probably disable the function and just use the regular link without comment display. Thanks anyway. :slight_smile:

It finally works ! :slight_smile:

It was fixed just after the last update of the plugin, with a fix for Discourse commentaries on WP in particular conditions.

Thanks ! :slight_smile: