Discourse Data Explorer Import no longer works?

I’ve been trying to import some SQL queries from one discourse forum to another. Worked fine for the last few years. However, now when I try to import a query it allows me to select it and then nothing happens. Thoughts?

1 Like

You’ll need to share more information like what the query was.

How are you trying to import them?


This is an example for one of the queries:

-- integer :page = 0

SELECT topic_views.*, single_sign_on_records.external_id, topics.title
from topic_views
left join single_sign_on_records
on topic_views.user_id = single_sign_on_records.user_id
left join topics
on topic_views.topic_id = topics.id
OFFSET :page * 1000

I try to import it using the import button and selecting the file (attached)
topic-views.dcquery.json (605 Bytes)


Using this button:

I hadn’t remembered that was a feature. When I try clicking import and selecting a file, nothing seems to happen.

It worked fine up until about October, you could export the json file and import no problem. Now as you say, nothing happens. Its much quicker than copying and pasting because I have a large number of files.

1 Like

You might move this to bug

1 Like

This is a side effect of this change (in pick-files-button.js):

By removing this.onFilesPicked(files);, you remove the action call defined here:


So this was a change made by Discourse so there isn’t a way for me personally to fix?


That’s right; it’s best to wait for a fix.


Thanks for reporting this! It should now be resolved :tada:


This topic was automatically closed after 42 hours. New replies are no longer allowed.