Data Explorer json import doesn't seem to work here

Running in one of my sandbox environments (a dockerized “normal” installation :slight_smile: ) - I exported a couple of data explorer queries so I could restore a more current backup from our production system, and expected to have to re-import the queries as we don’t have the data explorer installed in production.

I attempted to import both queries individually, but it did not show in the list once imported.

Running on version 3.2.0 with the data explorer plugin version 0.3. I don’t see anything in the discourse logs related to the import failing (or succeeding, for that matter).

1 Like

So, there is no visual error, and even after refreshing the page, you still see nothing. Is that correct?

Can you check the browser console if you see an error when importing? (usually F12)

That is correct - no visual error, the imported query just doesn’t appear.

No errors reported on the browser console that are related to the import, either (I cleared it, tried the import, and nothing showed up on the console).

There was a report of this a few weeks ago, which has now been fixed:

Though if you’re on 3.2 tracking the stable branch you may need to wait for the next release to pick that fix up.

1 Like

Good to know, thanks. I tried searching, but didn’t include that category it seems, so I missed it. Appreciate it!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.