Discourse install problem

Hi, I’m a new guy for install discourse .I am facing this problem .
When this step I input command " ./disdourse-setup"
my Terminal don’t show message "Ports 80 and 443 are free for use "
then show this message

"WARNING: Port 443 of computer does not appear to be accessible using hostname: "
“Connection to http://elearning109.zapto.org/(port 80) also fails.” etc.

How can i deal with this problem? thanks.

1 Like

You’ll have to see what service is listening to Ports 80 & 443. I’m assuming you’re trying to install discourse on a server with an existing website? If yes, You’ll have to temproarily shut down the web server to install discourse then configure discourse to run behind your existing webserver.

If no, You can check if a webserver is already running using command netstat -alpn | grep 80 or netstat -alpn | grep 443

2 Likes

Okay, I will check the port according to your suggestion, but my nginx service is working normally, I just wonder why the sentence “Ports 80 and 443 are free for use” is not displayed during the installation process.

Forgot to say, my system is ubuntu20.04.1 version, and the domain “http://elearning109.zapto.org/” is currently operating, which is the problem of discourse installation stuck in port setting.

The sentence is being displayed because of nginx running on the server.

When the external network is connected to “http://elearning109.zapto.org/”, the internal network ip is port forwarded through the router. Could it be that port:80 is occupied because of this?

Thank you, I success connect the port:80 through your method, but port 443 still has problems.

The message display
Hostname for your Discourse? [discourse.example.com]:

Checking your domain name . . .
WARNING: Port 443 of computer does not appear to be accessible using hostname:

SUCCESS: A connection to port 80 succeeds!
This suggests that your DNS settings are correct,
but something is keeping traffic to port 443 from getting to your server.
Check your networking configuration to see that connections to port 443 are allowed.

The first thing to do is confirm that resolves to the IP address of this server.
You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.
A web search for “open ports YOUR CLOUD SERVICE” might help.

This tool is designed only for the most standard installations. If you cannot resolve
the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app

This may be due to You using a free subdomain from noip

My router can’t setting https and port 443 only can setting port 80 and http .

Then you’ll need to configure discourse manually or run it somewhere that allows access to port 443

1 Like

Thanks my problem was sloved.