Discourse installation without SWAP

unsupported-install

(Hu Telestem) #1

Hello,
are there any way to install Discourse without SWAP, because my VPS uses OpenVZ.
I will not have too much posts and users, so 2gb of memory maybe enought?


(Jay Pfaffman) #2

You can edit app.yml by hand or comment out the part that checks for memory. Discourse will probably run, but will run out of memory when you try to upgrade, or perhaps, do the initial bootstrap.

If you do that and it doesn’t work, don’t be surprised.


(Rafael dos Santos Silva) #3

We don’t support installs in OpenVZ, you need a KVM compatible VPS.


(Hu Telestem) #4

Thank you for the answers, then I failed with OpenVZ

You can close the topic!


(Régis Hanol) #5