Discourse NOT FOUND


I am trying to install Discourse on linode with there one-click app
I ran through discourse-setup, and even tried rebuilding discourse!

The domain is setup correctly and I can ping it, and sometimes it says “welcome to nginx”, which is part of the docker container for discourse and not installed on the server.

The result of docker ps:

CONTAINER ID   IMAGE                 COMMAND        CREATED              STATUS              PORTS                                                                      NAMES
a494a72506a8   local_discourse/app   "/sbin/boot"   6 minutes ago        Up 6 minutes>80/tcp, :::80->80/tcp,>443/tcp, :::443->443/tcp   app

I noticed that when I ran ./discourse-doctor the last bit said:

Discourse version at forum.[redacted].com: NOT FOUND

Any help appreciated, thanks!

Hi @tpglitch :wave: welcome to Meta :slight_smile:

I think this topic may interest you:

might want to look at this too:

1 Like

These did not help unfortunately. :frowning:

My guess is that you have two A records for your domain


I do not, but I was able to get it working buy using a different subdomain.


Then likely DNS was broken at first and you retried a bunch of times and hit Let’s Encrypt’s rate llmits. ./discourse-setup tries to keep that from happening, but I guess Linode’s installer doesn’t use discousre-setup


It does use discourse-setup. It has to be manually ran by the user if you don’t automatically fill out all the fields on Linode (which I didn’t)

1 Like