Discourse not launching after upgrade

I just tried to update my forum to the latest 3.1 version (coming of 2.9) and now it won’t launch anymore. There is no error message displayed at the end to installation process as far as I can make out.

When trying to access the site I get this on a constant loop:
Screenshot 2023-01-19 at 12.22.32

I get this message whenever I STOP/START the forum:
WARNING: containers/app.yml file is world-readable

I power cycled the Digital ocean server but to no avail.

Anywhere I should look for an error?

Thanks!

This is not your problem, it is just advisory (but see: WARNING: containers/app.yml file is world-readable. You can secure this file by running: chmod o-rwx containers/app.yml - #10 by JammyDodger)

Please share the output of the browser console from the moment you open the page.

You also might want to perform a complete rebuild and share the build log output if it errors.

2 Likes

Do you have a reverse proxy or S3?

Have you tried safe mode?

3 Likes

If you can share a link so we can check it out that would be helpful. But you should also try safe mode, and check for any errors in your /logs or browser console too. :+1:

We had a couple of similar reports yesterday concerning the maths plugin, but they should be fixed now.

3 Likes

Thanks guys!

Safe mode thankfully works.

Browser window says:

I’ll disable Quick Messages and give it another go.

3 Likes

support for Quick Messages Plugin was ended some time ago.

3 Likes