Discourse Server logs show DB queries when I run the server

So I did all the setup and I was able to successfully run the server command - bundle exec rails server --binding= . But instead of seeing the message Server listening on PORT 3000, I only see DB queries as logs in the command line.

Can someone point to the direction, why I don’t see the server listening log ?

Is this for a local development instance, or are you setting up Discourse for general usage?

So I am running this inside a Ubuntu VM and once the server is up, I can access it using the ip address of the vm and port 3000. But ya for general usage.

Are you following our official install guide, step by step, with no deviation from those steps?

I was following this guide - Beginners Guide to Install Discourse on Ubuntu for Development

That’s a development install, are you a coder / computer programmer intending to write Discourse plugins or contribute to the Discourse open source source code? You said

For general usage follow the install guide I linked, you don’t want the development install.

I am a coder but I am not willing to write any plugins etc, just want to setup discourse forum add on for my website. Where people can go and share their topic of concerns and me and my team can answer them.

As I mentioned, follow the link in my above post for the official standard install :point_up::point_up:

got it let me do that, thanks a lot Jeff :slight_smile:

1 Like

But still I want to know why I keep seeing DB queries instead of server running ?

Hi @codinghorror is there a way to setup discourse on a gcp hosted vm ? or need to use digital ocean vm only ?

That is the standard output of the framework on development mode.

It works fine on GCP provided you open the necessary ports and select an instance type with enough memory.

Hi @Falco so let’s say I see the standard output on development mode, but if I go to that vm ip address and on port 3000, I don’t see anything, could there be anything that I am missing.

To setup discourse on gcp, I follow this url - https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md , instead of digital ocean, I created an ubuntu VM on gcp and tried the setup, when I came to the step of setting the hostname for my discourse , I have a registered domain but I wasn’t able to attach it and it gave me error.

By default development only binds locally, so other devices in the same network can’t browse it. You can use standard rails flags to change the behavior.

What do you mean by “attach” a domain?

Domain must point to the instance public IP, and instance must have the standard web ports open. One of the reasons we recommend Digital Ocean is that non-technical users have difficult opening ports in cloud providers, which doesn’t happen on simple VPS providers.

1 Like

Got it that’s helpful thanks a lot Rafael :slight_smile:

1 Like

You have to have a public ip for the virtual machine and create an A record that points to it.

If you want help, you’ll need to say what you did and what error you got. With dns issues you can get better help if you share the host name.

1 Like