Discourse Swap Memory (1GB Warning)


I attempted to install Discourse on a digital ocean droplet with 1gb of RAM, the installer stated I should ideally be using 2gb of RAM, it mentionned swap files and that I could potentially run into problems with future upgrades.

Therefore is it safe to start with 1GB and if required upgrade the RAM later - would Discourse automatically use the additional RAM or would one need to amend the configuration in some way to allow for more RAM in future - and if so how?

You can run on the 1GB of ram to start with however I believe you would need a 2GB swap file to go with it in order to allow it to peak when doing resource intensive stuff such as upgrades etc.

If you have the 1GB Ram + 2GB Swap it should keep you going for a while thats for sure.

There are many posts on the forum about it so worth having a search through


If you let it, ./discourse-setup will create the swap file for you and configure the OS to try very hard never to use it.

Perhaps I should add the bolded words the message below?


In 2017, The install used to create a Swap automatically when you didn’t have enough RAM.

It seems even if you add the swap manually, the install wouldn’t proceed.

I just tested an install on a new 1GB Digital Ocean droplet using our default cloud install instructions, and it worked fine:

root@delete-me-install-test:~# sudo -s
root@delete-me-install-test:~# git clone https://github.com/discourse/discourse_docker.git /var/discourse

Cloning into '/var/discourse'...
remote: Enumerating objects: 41, done.
remote: Counting objects: 100% (41/41), done.
remote: Compressing objects: 100% (28/28), done.
remote: Total 4455 (delta 15), reused 23 (delta 12), pack-reused 4414
Receiving objects: 100% (4455/4455), 968.00 KiB | 10.75 MiB/s, done.
Resolving deltas: 100% (2833/2833), done.

root@delete-me-install-test:~# cd /var/discourse
root@delete-me-install-test:/var/discourse# ./discourse-setup

WARNING: Discourse requires at least 2GB of swap when running with 2GB of RAM
or less. This system does not appear to have sufficient swap space.

Without sufficient swap space, your site may not work properly, and future
upgrades of Discourse may not complete successfully.

Ctrl+C to exit or wait 5 seconds to have a 2GB swapfile created.
2097152+0 records in
2097152+0 records out
2147483648 bytes (2.1 GB, 2.0 GiB) copied, 6.28174 s, 342 MB/s
Setting up swapspace version 1, size = 2 GiB (2147479552 bytes)
no label, UUID=2233bd64-65cf-4468-9548-ab7897657855
/swapfile       swap    swap    auto      0       0
vm.swappiness = 10
Ports 80 and 443 are free for use
'samples/standalone.yml' -> 'containers/app.yml'
Found 1GB of memory and 1 physical CPU cores
setting db_shared_buffers = 128MB
containers/app.yml memory parameters updated.

Hostname for your Discourse? [discourse.example.com]: 

screenshot of it up and running at the IP address:

So, I’m not sure what you’re talking about.


Yes very strange I retried and it worked as you have shown.

I’m using Amazon AWS on Ubuntu 18.04. Because of the bug I had, i had to upgrade my instance to get 2Go to be able to proceed with the setup.


I am in a similar situation. I’ve created a 2GB droplet with Discourse on DigitalOcean. I have this warning when I start the Droplet:

WARNING: Discourse requires at least 2GB of swap when running with 2GB of RAM
or less. This system does not appear to have sufficient swap space.

But the DigitalOcean documentation is recommending to not create SWAP space for a droplet using a SSD. And mine is using a SSD (like all droplets I guess).

So I am confused about what should I do. What would you recommend?

If you install following our Discourse official Standard Installation we will automatically set up swap for you, nothing you need to handle manually.