Discourse wizard page not displaying and missing dependencies


(Constantin Chirila) #1

Hello guys!
I just installed Discourss on my server, registered and activated the admin account and the next step was the wizard, which shows as an empty page: Image 2017-07-26 at 10.28.47 PM.png
I’ve also checked the console and it seams it missing ‘virtual-dom’ module: Image 2017-07-26 at 10.29.47 PM.png

Any ideas what’s wrong? It’s literally a brand new install with zero config. I tried rebuilding the app with no avail.

Thank you and i owe a beer to whomever can help!


SetupWizard, blank screen, JS Error "`virtual-dom"
(Felix Freiberger) #2

Did you install Discourse using these instructions? If not, how did you install Discourse?


(Constantin Chirila) #3

Hello Felix! Thank you for your reply!
Yes, I have installed exactly following those instructions.


(Felix Freiberger) #4

Weird! On my install, the wizard is loading fine, but I’m just tracking the beta branch.
You didn’t happen to install a plugin (by adding it to app.yml) before you got started?


(Constantin Chirila) #5

Nope, I’ve literally made a clean install, without changing anything. Mainly cause its my first time, so i don’t like adding complexity to the forum before understanding a bit about it.
I am pretty sure is the missing dependency. The rest of the forum seems to work, but it keeps bugging me to finish the wizard setup.
Do you recon i should give a different version a try? :slight_smile:


(Constantin Chirila) #6

I’ve completely removed and reinstalled and the same issue. I am on Linode server with Linux Ubuntu :frowning:


(Constantin Chirila) #7

Is the wizard important though? since i can change settings in the forum anyway and fully use it. I am thinking to just ignore it.


(Felix Freiberger) #8

Hm, in that case, I’d guess that there is a regression that broke the wizard – maybe a team member can check on that.

In the meantime, you can configure everything without the wizard, it will just be a bit more inconvenient.
If you decide to go for that route, be sure to look for alerts in the top-right corner of the admin dashboard – they will warn you about some important settings you should definitely customize :slight_smile:


(Constantin Chirila) #9

Thank you very much for the help!


(Aktiur) #10

Got exactly the same problem while attempting to install Discourse yesterday. I also followed to the letter the cloud installation instructions.


(Felix Freiberger) #11

If you haven’t completed configuring Discourse already, visit /admin/upgrade and update Discourse, then try again. @eviltrout has fixed the issue:

Thank you for reporting this problem! :slight_smile:


(Jeff Atwood) #12