Docker install: Module aufs not found - again


(Brahn) #1

Following the guide, I have tried at both SF and NYC regions with ubuntu 16.04 and cannot get past installing docker without first following the recommendations from this old topic.

sudo apt-get install lxc wget bsdtar curl
sudo apt-get install linux-image-extra-$(uname -r)
sudo modprobe aufs

Either I am doing something odd or the guide needs updating yeah?


(Rafael dos Santos Silva) #2

The first command of the guide(wget -qO- https://get.docker.com/ | sh) already install aufs for you if you are using a compatible server.


(Brahn) #3

Well, what I am saying here is that is not what is occurring on a fresh DO ubuntu installation. I have tried with both 16.04 and 16.10. The command wget -qO- https://get.docker.com/ | sh doesn’t run successfully. This is what I am seeing:

root@ubuntu:~# wget -qO- https://get.docker.com/ | sh
modprobe: FATAL: Module aufs not found in directory /lib/modules/4.4.0-57-generic

It continues doing its thing but is non functional at the end and so ultimately the discourse install is unable to bootstrap.


(Jeff Atwood) #4

Are you deviating from our official guide in any way? Are you selecting some kind of wacky pre-built droplet, or a clean Ubuntu Server 16? Because @pfaffman and I have installed dozens of times following that guide step by step on Ubuntu 16.04 LTS server droplets and we had zero issues.


(Brahn) #5

I just did it a moment ago. Exactly these steps:

  • New droplet, ubuntu 16.04.1 x64
  • 2GB
  • NY2
  • SSH Key
  • Log in to new droplet as root
  • execute wget -qO- https://get.docker.com/ | sh
  • modprobe: FATAL: etc…

Could it be datacenter specific?


(Jeff Atwood) #6

I can try to repro later. Out with the family at the moment.


(Blake Erickson) #7

I’m also getting this error.

Does following the steps in this topic help?


(Brahn) #8

Yes, but you have to do them before you ever try to install docker. The same ones I mention at the beginning of this topic.


(Blake Erickson) #9

okay so yes I got that error:

but the discourse install worked fine:


(Blake Erickson) #10

So I just tried again on a fresh local virtual box VM of ubuntu 16.04.1 x64 and I didn’t get the error:


(Jeff Atwood) #11

It looks like you are reporting something as an error that’s not really an error?

I just set up Discourse on a new SFO 2GB Ubuntu 16.04 LTS droplet. I do see the “error” but it just scrolls on by and everything works fine – Docker seems plenty happy, note aufs is there:

root@ubuntu-2gb-sfo2-01:~# docker info
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 0
Server Version: 1.12.6
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 0
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: null host bridge overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: apparmor seccomp
Kernel Version: 4.4.0-57-generic
Operating System: Ubuntu 16.04.1 LTS
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.953 GiB
Name: ubuntu-2gb-sfo2-01
ID: BBSH:HMBA:FO7I:WMZD:GR7R:2EAM:KL5A:XCZ3:JOMM:YQQW:ATEZ:SHZF
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No swap limit support
Insecure Registries:
 127.0.0.0/8

After bootstrapping it loads Discourse just fine, following the official install guide, step by step, no deviations.


(Brahn) #12

I will try to reproduce further then/again.


(Brahn) #13

Oh dear. I really cannot get it to fail now (that FATAL: Module aufs not found is still there but everything else works as it is supposed to). I was so convinced Iit was a problem further down the line. Very sorry guys and thanks for all your help!


(Jeff Atwood) #14