Unable to install Discourse: module aufs not found


(Prateek) #1

When i do wget -qO- https://get.docker.com/ | sh

The very next line says modprobe: FATAL: Module aufs not found.

But the installation continues, but after doing “./launcher bootstrap app” and “./launcher start app” i get fatal errors.

I am following the OFFICIAL install guide steps on a standard ubuntu 14.04 LTS. Whatsup?

(PS - my email SMTP credentials are correct)


(Jeff Atwood) #2

Docker is not installing properly. Until docker is installed properly nothing will work.


(Prateek) #3

…how can i install it properly?


(Rafael dos Santos Silva) #4

PS: What’s your vps provider?


(Prateek) #5

this one is on OVH.
I don’t understand, if it is a standard Ubuntu 14.04 LTS, what could be different?


(Prateek) #6

OK…

This is the 4th time i tried to install, after trying the “fix” in the thread provided by @Falco which is

sudo apt-get install lxc wget bsdtar curl
sudo apt-get install linux-image-extra-$(uname -r)
sudo modprobe aufs

I still get the error:

FAILED
--------------------
RuntimeError: /usr/local/bin/ruby -e 'if ENV["DISCOURSE_HOSTNAME"] == "discourse.example.com"; puts "Aborting! Domain is not configured!"; exit 1; end' failed with return #<Process::Status: pid 219 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "/usr/local/bin/ruby -e 'if ENV[\"DISCOURSE_HOSTNAME\"] == \"discourse.example.com\"; puts \"Aborting! Domain is not configured!\"; exit 1; end'"
d0ee9b65b9f5191547ee326f11251162835f0dc68446622349ccae6cf07bb214
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(Jeff Atwood) #7

It says the domain is not configured in the error you posted. Make sure docker info shows aufs as the filesystem and docker version is correct.


(Prateek) #8

docker info

Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 1
Server Version: 1.11.0
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 6
 Dirperm1 Supported: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins: 
 Volume: local
 Network: null host bridge
Kernel Version: 3.13.0-55-generic
Operating System: Ubuntu 14.04.4 LTS
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 1.908 GiB
Name: sitename.com
ID: 46DY:WHRC:PSQ2:Q3PG:KR2N:QEN2:2YZ2:SOOX:4HRQ:CLFH:7ZHY:5MYD
Docker Root Dir: /var/lib/docker
Debug mode (client): false
Debug mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No swap limit support

docker version

 Client:
 Version:      1.11.0
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   4dc5990
 Built:        Wed Apr 13 18:34:23 2016
 OS/Arch:      linux/amd64

Server:
 Version:      1.11.0
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   4dc5990
 Built:        Wed Apr 13 18:34:23 2016
 OS/Arch:      linux/amd64

(Jeff Atwood) #9

That looks fine now. Read the error. Your domain is not configured in app.yml


(Prateek) #10

When i do a nano containers/app.yml , it opens a new file now? Wut? What is this now? — this was my stupidity.

Here is my domain in my app.yml

DISCOURSE_HOSTNAME: 'discourse.example.com'

(Rafael dos Santos Silva) #11

You are expected to change example.com to the domain you bought.


(Prateek) #12

The instruction —

Set DISCOURSE_HOSTNAME to discourse.example.com, this means you want your Discourse available at http://discourse.example.com/. You’ll need to update the DNS A record for this domain with the IP address of your server.

I really think that you should specify it more clearly there.

And i changed discourse.example.com to mydomain.com, not just example.com

It is working fine now…
Thanks.


(Stefano Costa) #13

For the record, you automatically get a domain like vps12345678.ovh.net with all OVH VPSs, it turned out to be useful for testing.