Email for new user not sent

we have just set up discourse and all is fine until first user signed in …in log says user was created fine i have him marked as grey in list …testing mails come to my inbox but in email diary/log section there is clearly lacking record in sent category for new user… waiting time for new user is currently set as 8 hr but user was created 18 hr ago…he now waits for confirmation mail.

Have you checked Troubleshoot email on a new Discourse install?


Have the user check Spam box. As often emails from a forum might initially end up there depending on there email settings.

Your mailserver provider may also have tools you can use ti check and see if the email was sent out.

1 Like

Hello and welcome @stormfinger :slight_smile:

So, in your logs there are entries for emails that have sent, and that you’ve received? But there isn’t a log for sending the signup email to this new user?

It may be worth checking if disable emails is set to ‘staff only’. There should be a banner showing, but just in case there’s not it’s a good place to start. :slight_smile: :crossed_fingers:

1 Like

i will check logs provided in page mr. Jay suggested i checked some logs i ve seen that user was created no sign of error …i am with contact with user he seems fairly educated …so i guess he did check the spam filter but am waiting for confirmation … yes logs for sent mail show few mails that were sent from discourse system including my own test mail but users mail isnt there nor in any category …ill also check right now for disable_emails settings [EDIT] …mails are not disabled we also have saml which is running perfectly and would like to thank for all hard work …we only have issue with new members creating profile at discourse forum …we have this settings empty …and i even dont understand what hint of the field is trying to explain " site contact group name" = A valid name of a group that gets invited to all automatically sent private messages. …this makes no sense to me but am new also dont know where to read for more information .

ive now tried under another mail to sign in …says mail has been sent tho its not visible in system under settings emails. i have checked the log theres no dates??? no time??? last lines are

/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/message_bus-4.2.0/lib/message_bus/backends/redis.rb:379:in `process_global_backlog'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/message_bus-4.2.0/lib/message_bus/backends/redis.rb:286:in `block in global_subscribe'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/message_bus-4.2.0/lib/message_bus/backends/redis.rb:299:in `global_subscribe'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/message_bus-4.2.0/lib/message_bus.rb:763:in `global_subscribe_thread'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/message_bus-4.2.0/lib/message_bus.rb:734:in `block in new_subscriber_thread'

Did you follow the steps in the troubleshooting guide? Can you send to mail-tester?

hi Jay …i can send test meil from forum settings to my inbox yes. that was already configured by my previous admin …but new users dont receive email … i created myself user and did not receive automatic mail for confirming email address and email is not in spam box… ill try now regenerating the app as mentioned in troubleshooter im out of ideas … i did delete a forum category that was i think generated by forum itself couse we see no use for it but i dont know if that is relavant.

1 Like

something is fishy :smiley:
i tried to rebuild with

cd /var/discourse/
./launcher rebuild app

got into trouble got doctor seting following diagnose

==================== SERIOUS PROBLEM!!!! ====================
app not running!
Attempting to rebuild
==================== REBUILD LOG ====================
x86_64 arch detected.
docker: Error response from daemon: OCI runtime create failed: container_linux.go:367: starting container process caused: process_linux.go:495: container init caused: process_linux.go:458: setting cgroup config for procHooks process caused: can't load program: operation not permitted: unknown.
Your Docker installation is not working correctly

==================== PLUGINS ====================
          - git clone
          - git clone
          - git clone

but forum is still working tho docker doesnt run …or seems to fail due to running in LXC …seems our forum runs without docker tho i did just menage to get docker up and running but its question if itll be allowed solution …so any non docker help is still very welcomed :slight_smile:

1 Like

Hi stormfinger!

I’m unable to help on this, but I just want to be sure on how you installed Discourse since you says that “seems our forum runs without docker”,“I did just manage to get docker up” and “any non docker help is still very welcomed” so I’m a bit confused.

Is your Discourse forum a standard install (using docker), or did you install it differently?

You’ll need to get help from whoever installed it. It sounds like your VM isn’t able to run docker, so you can’t use a standard install.

If you want help here, you’ll need to move to a VM that can run docker.


ok thank you ive set up lxc so it can run docker and am in progress of installing discourse as suggested.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.