Email headers showing post ID #

#1

Hey guys,

I have seen this tutorial, but I can’t solve this issue.

My email subject is the one that comes by default:
[%{site_name}] %{optional_pm}%{optional_cat}%{topic_title}

But my emails come like this:
[Foro de NewEsc] [Smartphones/Xiaomi] Tema #116

image

So, instead of the Topic Title, it shows the number :open_mouth:

Is there something I Need to change?

Thanks

2 Likes
(Simon Cossar) closed #3
(Jothan Frakes) #5

on email subject line, topic_title token is being sent as the topic id # instead of the actual text of the topic

How does one make the topic text instead of the topic number?

3 Likes
Customize subject format for standard emails
(Simon Cossar) opened #6
(Régis Hanol) #7

@maja this is not the first report I’ve seen about this issue. Can you try to reproduce?

2 Likes
(Maja) #9

@mingogomes, do you possibly have private_email setting enabled? That would exclude post content from emails and add a generic title.

I wasn’t able to reproduce the issue with private_email disabled.

5 Likes
#10

Thanks a lot Maja!
It was that indeed :smiley:

2 Likes
(Régis Hanol) #11

Should we improve the copy of the site setting?

We currently have this

Don’t include content from posts or topics in emails for extra privacy. NOTE: also disabled digest emails.

Maybe we should change it to this?

Don’t include content from posts or topics in emails title and body. NOTE: also disables digest emails.

1 Like
(Jeff Atwood) #12

Try

Don’t include content from posts or topics in email title or email body. NOTE: also disables digest emails.

1 Like
(Régis Hanol) #13

Done in

3 Likes